Is there something I am doing wrong with Cyberpunk 2077?

Hi there everybody!

I am new to Linux somewhat and pretty new to Manjaro (recently switched from Pop! OS)

I am trying to get Cyberpunk going on my Manjaro GNOME install, however, I am running into some issues that I can’t seem to figure out. I am running this through Steam Play

The game runs fine for the first run after an uninstall and reinstall, but, after that it seems to fail to load a save and crash during the loading of that save. Below are the details of my system and also what I have tried.

Tried Proton versions:

  1. 6.3-5
  2. 6.10-GE-1
  3. 6.12-GE-1

I am running the CyberEngine Tweaks Mod, I have tried both with the mod and without (reversing anything that I did before installing CET) and still seeing the same behavior

I am using wine-staging 6.12

My system specs are below:
i7 8700k
Nvidia 3070 - running the 470.42.01
Kernel - 5.10.49-1

I am still pretty new to all this (I would say beginner that can be dangerous? :wink: )

Any help would be very nice…I am in love with Manjaro and really liking everything about it so far!


I have tried that version of Proton already, but I am still seeing crashes when trying to load a save with that version.

Like I said it works when I uninstall, reinstall and then load the game and it works really well for that session…it seems that it is after this that it is failing to load the save.

I did find this in the forum…Related maybe?

Unlikely, that just seems like your typical complications by people using unsupported configs.

I assume you disabled ray tracing and DLSS?

Yes they are disabled. Those are actually greyed out for me.

And what if you don’t?

I have reverted the mod and deleted the folder containing the modified prefix. After doing this game still seems to fail at roughly the same spot after recreating a default prefix. I noticed that there is a lot of popping and the frames are jumping from 2-60fps during the time leading up the crash…I am suspecting that this is due to the graphics driver, but I am not sure how to validate that.

Since I am using an Intel CPU could it be possible that the game is using the integrated graphics instead of the GPU? That would explain why it isn’t allowing me to turn those settings on right?

EDIT: Nevermind I am seeing it in nvidia-smi

0 N/A N/A 11096 C+G ...bin\x64\Cyberpunk2077.exe 2266MiB

Been driving myself mad, found this on the r/linux_gaming subreddit

Apparent memory leak in DX12 games with Nvidia 470 drivers

EDIT: I think that I just confirmed it. I turned on Mangohud to monitor the memory usage of both VRAM and RAM. RAM just kept climbing…also turned on monitoring of the swap and was seeing that it was climbing as well. I have 16GB of Memory and 10GB swap, and both ended up maxing out when I was trying to load a save at which time the game had crashed. I guess this is a bug with the driver?

And only happens with DX12 games? I’m don’t notice any issue with DX11 games (DXVK) (at least yet).

I played Sea of Thieves, Killing Floor 2, and Deep Rock Galactic recently and didn’t notice any issue. I didn’t monitor though, so maybe it was swapping a lot :smiley:

I only have 16GB of memory but I was noticing loading into the main menu It went up to 12.6GB and 1.8GB swap. When loading the save it went up to 15.8GB and ~9GB swap and then the game crashed :frowning:

Cyber punk has been my main game that I play here recently. But I will try Sea of Thieves today to see what the usage is there. But if I am not mistaken Sea of Thieves, and Killing Floor 2 are both DX11 games. I will look to see if I have any other DX12 games to see if the same behavior is seen there.

Maybe it’s because Proton needs to be refreshed because of the large changes in Wine version?

Follow the instructions and don’t forget to do a saves backup for a refreshed Proton:


Ah yeah, I remember reading that release info. But anyway it is always a good point to reset the prefix to start fresh when you have issues with Proton.

Alright I will give this a shot. I may have been resetting the prefix wrong anyway so this will be a good safety measure. Thanks for sharing this.

This did not seem to help…but it gave me an idea to maybe get off of wine-staging and go to stable. However, I deleted the prefix following the steps above, still crashed with absurd RAM and swap usage.

Then I tried with deleting the prefix again and wine-stable branch, and still same results, sadly…I am still thinking that this may have something to do with the Nvidia driver with VKD3D games. Is there a way to go back to the 465 version? I tried looking to see if it is available through pamac but I don’t think that I saw it as an available package.

I did check to make sure that I had some other games that were installed that are on DX12 to confirm but sadly I don’t have anything to compare.

Honestly I would suggest playing this title on Windows. It already has stability issues on Windows, best not add onto the list of possible issues.

I suggest you try the updated driver on the Testing branch. You just need to switch from Stable branch to Testing branch, refresh mirrors and their databases, and update the system.

No there isn’t (unless you know what you’re doing but you wouldn’t ask then). Also you NEVER manage your video drivers from pacman or pamac. Manjaro created tools to do that, so use these specific tools to install/remove video drivers. In Manjaro Settings Manager, under hardware, here it is. Same goes for kernels, you manage them from the dedicated tools provided by Manjaro.

1 Like

New stable update (today) has fixed the problem for me. Updated nvidia driver to version 470.57.02.