Is there a way to tell my system to assign half my ram to the gfx card?

I have 15GiB of ram and plenty of 16GB USB sticks I can pick from to dedicate to swap space but only 512MiB of gfx ram. As a result of this I would like to just tell my system to assign half my ram to the gfx card for it to substitute it’s lack thereof while my system uses one of my USB sticks to supplement the lost memory. Btw I’m on Manjaro XFCE x64 Minimal so I would likely haft to install 1 or 2 things

Edit: I should also mention it’s an all AMD build from TUXEDO Computers, ryzen 7 with radeon graphics

Hi @zxuiji,

AFAIK if your gfx isn’t integrated, then no. Also, using a flashdrive for SWAP space is a Bad Idea :tm: .

3 Likes

This is done - if possible - at firmware level.

It may be possible with some AMD GPU but that depend on your GPU and system in general.

https://sx.nix.dk/search?q=ryzen%207%20radeon%20assign%20more%20memory

2 Likes

First of all, assigning more or less of your RAM to your on-board GPU is done through your UEFI or BIOS settings — there’s nothing that the operating system can do about that.

The default setup is to use approximately 1/32 of your available RAM, i.e. … :arrow_down:

 8 GiB of RAM →  256 MiB video RAM
16 GiB of RAM →  512 MiB video RAM
32 GiB of RAM → 1024 MiB video RAM
64 GiB of RAM → 2048 MiB video RAM
...

Of course, in many cases the UEFI or BIOS firmware allows you to increase or decrease the amount of RAM dedicated to the onboard GPU. But even then there’s a limit. If you truly want 8 GiB of video RAM, then you’ll need to get yourself a discrete graphics adapter.

Secondly, USB sticks are not RAM and cannot be used that way. They aren’t even usable as swap memory, because (1) they are way too slow and (2) most of them do not support the TRIM functionality, so they also have very limited lifespans when written to a lot.

The bottom line is that your plan is completely based upon the wrong assumptions.

3 Likes

Got it, I’ll take a look at the UEFI settings once I find the thread that mentioned how to tell grub not the skip past the menu that would allow me to access the settings (had to do a fresh install of manjaro, possibly due to the switch of arch from svn to git, may have caused incompatibilities that proved fatal to installing anything)

Edit your /etc/default/grub and change the line… :arrow_down:

GRUB_TIMEOUT_STYLE=hidden

… into… :arrow_down:

GRUB_TIMEOUT_STYLE=menu

Then, run… :arrow_down:

sudo update-grub

:wink:

1 Like

thx :slight_smile: I’ll give it a try later, in the middle of cooking and want to give more attention to that for obvious reasons

Edit: done with grub, about to reboot now to try, let you all now in a few minutes if I succeeded

Edit 2: Yep, that worked, “About Xfce” now reports 8GB of gfx ram and just under 8GB of normal ram, I’m sure the system now makes use of that swap space :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.