Is there a way to let a USB device be shown always in the state "connected"?

I want to use a version of Code Composer Studio that is only working on Windows. So I’ve decided to let it run in a VM. The JTAG is recognized, but when I try to flash the USB connection is disconnected. I think this might happen on actual Windows too, but the problem in the VM is that I have to check the device in the USB section again. During this time the flashing process fails. So is there a way to make Virtual Box think that the device is always connected. In Virtual Box itself there doesn’t seem to be a permanent filter option, so I though maybe from the Linux side something could be done to make Virtual Box believe the device were always connected.

If the device is not used by the host you could experiment with the USB tab for the VM.

You can add a filter which in case of a match the device will always be attached to the VM.

I rarely mention this because some new to VirtualBox gets the impression it is needed for any USB device - and that would be a mistake.

Nah this is what doesn’t work. It disconnects during debugging or flashing. Guess I can forget this on a VM

Have you tried making sure that the USB is always connected on startup in Linux?

The easy way is to download GNOME Disks, open it…

  1. Click on the USB you want to mount from the list

  2. Click on the small cog icon showing under the blue volume bar

  3. Select ‘Edit Mount Options’

  4. Disable ‘User Ssssion Defaults’

  5. Check ‘Mount at system startup’

  6. Check ‘Show in user interface’

Hope this is of help.

@tinkerer: It is not a USB storage, but an embedded real-time DSP development board . Guess I did not make that clear enough. Unfortunately Texas Instuments has never written a USB driver for the JTAG that works on the Linux version of Code Composer Studio and since the development board is 15 years old, they will not do it anymore. So I have to boot Windows to flash this thing and I really don’t like to do that. But I guess I have to swallow this bitter pill :wink: