Is there a way to enable classic horizontal menubar in FreeCAD application-specific settings?

Enjoying KDE, had this problem before, menubar missing from FreeCAD. used search, found that disabling the background service “application menus daemon” which I am about to do, but I’d rather not do that if there’s a smarter way. FreeCad community doesn’t seem to think it’s FreeCAD’s fault. This issue seems to go back for ages. Is there an override in specific window settings or a config file?

How was freecad installed?

From the repos? As a SNAP?

If you think you found similar reports with fixes please link them.

I used Pamac to install FreeCAD from the Official Repositories (extra)

your question caused me to try deleting that version and install the version from Flatpak and the issue is resolved. I’ve re-enabled the application menus daemon as well.

Thank you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.