Is OpenVPN functional with Network-Manager?

This is a query as much as an issue.

After the most recent stable update, I saw that network-manager gave the option (in the settings gui) to import an ovpn file and setup an openvpn connection (on pinephone - manjaro phosh). I figured I’d give it a try - I downloaded the file (proton) and used it to create a connection, just as I would on the desktop. It seems that this has not worked, though. running ip address, I don’t see any vpn addresses pop up. But, running journalctl -b -u NetworkManager --no-hostname --no-pager, I see errors among the output that at least says there was an attempt:

Jun 29 17:34:52 NetworkManager[3735]: <error> [1624952092.5725] audit: failed to open auditd socket: Protocol not supported
Jun 29 17:34:52 NetworkManager[3735]: <info>  [1624952092.5760] audit: op="connection-activate" uuid="c2a13904-6bab-4766-81ac-fe974aaa0d3d" name="hun" pid=4727 uid=1000 result="success"
Jun 29 17:34:52 NetworkManager[3735]: <info>  [1624952092.6675] vpn-connection[0xaaaaf1318170,c2a13904-6bab-4766-81ac-fe974aaa0d3d,"hun",0]: Started the VPN service, PID 4742
Jun 29 17:34:52 NetworkManager[3735]: <info>  [1624952092.7614] vpn-connection[0xaaaaf1318170,c2a13904-6bab-4766-81ac-fe974aaa0d3d,"hun",0]: Saw the service appear; activating connection
Jun 29 17:38:52 NetworkManager[3735]: <error> [1624952332.9984] vpn-connection[0xaaaaf1318170,c2a13904-6bab-4766-81ac-fe974aaa0d3d,"hun",0]: Failed to request VPN secrets #3: No agents were available for this request.
Jun 29 17:38:53 NetworkManager[3735]: <info>  [1624952333.2419] vpn-connection[0xaaaaf1318170,c2a13904-6bab-4766-81ac-fe974aaa0d3d,"hun",0]: VPN service disappeared

Would anyone know if getting openvpn connections to work via network manager is possible in Manjaro ARM? If so, how would one begin to ameliorate these errors?

Yes it is possible and it’s working fine on pinebookpro kde edition no idea about how to bring it up on pinephone.

1 Like

Okay, interesting. This infers that it is not a general ARM issue, at least. I thought that the line in the post inferred some fundamental ARM issue. Perhaps this is an issue with the Pinephone interconnectivity specifically?

1 Like

Okay, so I have come across a similar reported problem here. In this link, the same vpn error message comes up and there is a solution to the problem. I have tried it; ln -s /usr/lib/networkmanager/nm-openconnect-auth-dialog /usr/lib/gnome-shell/, but no sucess. I still get the same error. The original post entity does say that there is a solution but inexplicably does not actually leave it in the post, just a cryptic message that “saving password for everyone was the solution.” As such, I am still at a loss.


Thanks, mate. You’re a legend. Just to note: click the icon that is moused over in the screenshot above and a pop-up menu will open. In this menu, select the “store the password for all users” option. The iconshould change to reflect the new selection (the ‘i’ dissapears)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.