Is mouse cursor centering the workspace a feature or a bug?


I checked the Wiki at Github but couldn’t find an info mentioning this, so in conclusion I thought it could be a bug because it’s not always happening. When I change the workspace (super + number or just clicking the panel), mouse cursor jumps to the center of the workspace. If it’s a feature how can I disable it? If it’s a bug, this is a feedback.

It’s a feature, see man bspc for the exact command. The settingis something like mouse_follows_focus. Also one the scripts bound to the window moving keybindings might be affecting that setting.

1 Like

Thank you for the reply. Checked bspwmrc and found something similar. Changed this line true to false and I’m all good. :slight_smile:

bspc config focus_follows_pointer false

Edit: I guess I should sleep, this doesn’t make sense at all. I just disabled mouse hover focus. :sleepy:

Edit #2: I think this time I found it. Just reversed the order, haven’t checked the result but will probably work. It seems it’s enabled by default and wasn’t in the config file, had to add this line:

bspc config pointer_follows_focus false

Edit #3: This is the solution. Also as @kainonergon mentioned below, there is a toggle option.

Hi. You can also toggle that setting on the fly from pop-up menu (Alt + middle button) “Toggle pointer follows focus”.

1 Like

That setting might not stick though, I don’t remember what I coded anymore :sweat_smile:

Thanks for the tip. Most likely I won’t use it on desktop but could be useful for laptop.
By the way, since this is a bspc rule, can we toggle any other rules as well?

Yes, anything can be toggled.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.