Is it safe to disable kscreen2 service?

Disclaimer: It is not a problem, just inconvenience.
I have main monitor and a tv both on HDMI. TV is swiched off most of the time. Every time I turn it on I shoud go to settings and enable it in “Display and Monitor” section. Workarounds which worked for me:

  1. $xrandr --output HDMI-1 --auto --output HDMI-2 --auto --right-of HDMI-1
  2. display configuration icon in system tray
  3. and finally pause kscreen2 service in System Settings>Startup and Shutdown>Background Services

My question is if it is safe to disable the service on startup?

I have latest stable manjaro installed (Plasma 5.26.4)

1 Like

I’m running without kscreen2 for months now without any issue. I had a similar issue with 2 monitors connected with DP and HDMI. Turning on and off the HDMI monitor was always “re-arranging” my Desktop…
The time I need to spend updating my config is in no relation to kscreen2 doing it for me on a daily base :slight_smile:

Thank you Pinsch. Disabled it. Now I’m happy!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.