Is it possible to make Audacious entirely dark?

I’m using black theme for xfce and Audacious is not following it. It is because it’s QT5 based.

  1. Is it possible to make it GTK based somehow? Some other install?

  2. Changing QT5 settings to dark does nothing. The screen is the same.

Welcome to the forum! :vulcan_salute:

No, it is not. It’s qt5-based, and gtk is an entirely different widget toolkit.

audacious comes with a bunch of different skins that you can try out. This should be configurable from within the application itself.

Audacios was a gtk app - originally gtk2 - a gtk3 version exist in AUR - now it is based on qt5. As I recall it - I maintained audacious gtk3 for some time (for Manjaro building for openbox edition - nothing more) - gtk3 is not the primary focus - qt toolkit is.

That means you may need to use kvantum for theming - if supported as per @Aragorn comment below.

1 Like

Not all qt applications support this anymore. krita for instance doesn’t really follow the kvantum theme beyond the color scheme, and neither does strawberry.

1 Like

I’m using xfce and can get audacious completely dark when I set QT5 Settings (qt5ct) style to “gtk2” and pick a dark GTK theme.


Audacious running in Qt mode:

In Audacious 4.3.1 Settings → Appearance, I have;

  • Interface: Qt Interface
  • Theme: Native
  • Icon theme: Native

which allows audacious to follow the System theme; in this case, ‘Breathe Dark’ on KDE Plasma.

I hope this is useful.

Works perfectly fine in mine case too, on xfce. It follows the settings in Kvantum as any other qt app.
Settings in Audacious: Running in Qt mode, Qt interface, Theme Dark,
Settings in Qt5c: Kvantum-dark
Settings in Kvantum: your favorite dark theme, Matcha-dark modified in my case.

Thanks with those suggestions but nothing happens.

In Audacious it is set

Interface: QT Interface
Theme: Native (when I set Dark it’s even worse)
Icon theme: Native

In QT5 Configuration tool

Style: kvantum-dark, palette Default

Changing the style from kvantum to kvantum-dark makes absolutely nothing.

I don’t have any other Styles in QT5c except kvantum, kvantum-dark, Windows, fusion

I don’t have any gtk style listed. Only Kvantum/dark, Fusion and Windows.

Yes you are on the right track.

yes that is theme dependent, and probably not needed, but remember to toggle it after theme change just to be sure

That is actually a bug i think but the developers should say. I keep it on dark just to be sure…if at some update it gets fixed not to wonder what happened. But right now it is in deed not changing anything, that is to be expected.

You do not need anything else than kvantum (dark). Set it and forget it. It just tells it to look for the style at kvantum.

So you are only missing the last step. Open settings and then Kvantum Manager and select something dark. For example matcha. If you for some reason do not have it, the package is kvantum-theme-matcha

Oh yes, kvantum is an alien in xfce, but you need to set kvantum-dark theme in kvantum and choose one of the of the styles, like gnome-dark etc…

Wooo! That helped.

The last step in Kvantum Manager (changing and using matcha-dark) was crucial and only needed. Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.