Is it possible to have Linux subsystem for Android

After windows having Linux and also running android apps soon, is it possible that we at Linux can do 10x times or 100x time than what Windows can ever achieve and how
Is there some project which stats android will be supported in linux
Other than Anbox,
(I want something which is native to linux)
because they only support x86 arch and not regular apps

Thanks in advance

Its not what your looking for but there’s fydeos. It’s a chromium fork that runs android and Linux as well.

I dont want to leave Manjaro, I want something within

no, lack of funding, lack of programmers, etc…

Hello have u tried android x86( You can run it on virtualbox. It is true that it only supports x86 apps but many apps have x86 apks. Check at can trust this site). Also you can get genymotion from aur. Just create an account and chosse free for personal use. Its an android emulator based on android-x86

Both android x86 and Genymotion slows down my potato pc
I stop in between app installation process
I have tried it.
Android x86 and Genymotion are resource based and also android studio
I was a windows user and I know how my PC copes up with bluestack
They are no where near
But thanks for the idea

You’re using KDE which is quite heavy and on top of that using a VM. If you have a potato PC use xfce. Install androidx86 to your disk as its much faster than VM.Pls share the spec of your PC.

inxi -Fxz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_IN.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Portable System: Dell product: Inspiron 3537 v: A10 serial: <filter> 
           Mobo: Dell model: 033CY6 v: A00 serial: <filter> UEFI: Dell v: A10 date: 01/24/2018 
Battery:   ID-1: BAT1 charge: 17.6 Wh (80.0%) condition: 22.0/32.6 Wh (67.5%) volts: 15.9 min: 14.8 model: LGC DELL 49VTP27J 
           status: Discharging 
CPU:       Info: Dual Core model: Intel Core i3-4010U bits: 64 type: MT MCP arch: Haswell rev: 1 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13573 
           Speed: 798 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: radeon 
           v: kernel bus-ID: 03:00.0 
           Device-3: Microdia Dell Laptop Integrated Webcam HD type: USB driver: uvcvideo bus-ID: 1-1.8:7 
           Display: x11 server: X.Org 1.20.11 driver: loaded: ati,intel,radeon unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
           Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: 4000 
           bus-ID: 01:00.0 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Dell driver: ath9k v: kernel 
           port: 4000 bus-ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-1.5:14 
           Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends 
Drives:    Local Storage: total: 523.37 GiB used: 55.09 GiB (10.5%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
           ID-2: /dev/sdc type: USB vendor: HP model: x796w size: 57.61 GiB 
Partition: ID-1: / size: 48.97 GiB used: 13.98 GiB (28.5%) fs: ext4 dev: /dev/sda3 
           ID-2: /boot/efi size: 1023 MiB used: 312 KiB (0.0%) fs: vfat dev: /dev/sda1 
           ID-3: /home size: 97.93 GiB used: 4.34 GiB (4.4%) fs: ext4 dev: /dev/sda4 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A gpu: radeon temp: 48.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 221 Uptime: 8h 47m Memory: 5.68 GiB used: 3.19 GiB (56.2%) Init: systemd Compilers: gcc: 11.1.0 
           Packages: 1356 Shell: Bash v: 5.1.8 inxi: 3.3.06

As per your saying can I work and operate android together
I want when someone comes to check on me will alt+tab save me

If you have an ARM notebook and run Manjaro-ARM, will it be easier to run Android apps?

Its possible. But who going to invest in it? VFIO/KVM improved because it has enterprise benefits. Sadly linux development mostly focused on enterprises.

Just for clarification:

  1. Windows runs Linux (WSL) and Android through virtualization. The same can be done with Linux. Qubes is an example. A similar way like Qubes is done on Windows. The Windows Subsystems works ONLY with isolated virtualization.
  1. Anbox runs on the real Linux Kernel like Wine. Anbox is just a translation layer which translates the API Calls and so on. But it is far from being mature. There is no alternative to Anbox if you need something “native”. While Android is based on Linux, it is not the same, since it uses also other Libraries.

have you heard of waydroid? It’s an Anbox fork.


I was reading the above mentioned article and I found


The main catch right now is that there’s no emulation layer in WayDroid, so x86 devices (like most PCs) can only run x86 binaries, and ARM64 devices (most phones and tablets) can only run ARM64 binaries. This is similar to how the Wine compatibility layer works — even though Wine is available for Android, it can’t run most Windows software on most Android devices, since phones are typically ARM and most Windows software is x86-only. The developer is hoping to implement emulation in the future by using components from the Android subsystem for Windows 11.

That is also a problem because some social media apps only allow arm to do something specific task (talking about social media sites like insta and so on)

But thank you for your inputs :blush:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.