Is it possible to deactivate the "stereo repeat" option?

Is it possible to deactivate the “stereo repeat” option?
If I use VLC for example to play STEREO music the channels get copied like this:

Left → Left
Right → Right
Left → Surround Left
Left → Surround Back Left
Right → Surround Right
Right → Surround Back Right
Left + Right → Center
Nothing → Subwoofer

But if i play a 5.1 File this happens:

Left → Left
Right → Right
Center → Center
Subwoofer → Subwoofer
Surround Left → Surround Left
Surround Right → Surround Right
Left Center + (Subwoofer) + Surround Left → Surround Back Left
Right Center + (Subwoofer) + Surround Right → Surround Back Right

Is it possible to deactivate this feature? I don’t exactly know if this issue is caused of PulseAudio or ALSA because i use JACK between them.

/etc/pulse/daemon.conf contains a default setting: ; remixing-use-all-sink-channels = yes

I copied /etc/pulse/daemon.conf to $USER/.config/pulse/daemon.conf and added

; remix to the minimal set of sink channels needed to reproduce all of the source channels
remixing-use-all-sink-channels = no

Thanks for the suggestion!
Sadly it didn’t work. I have uncommented remixing-use-all-sink-channels = no and i even have turned enable-remixing to off (and uncommenting it too) to this:

enable-remixing = no
remixing-use-all-sink-channels = no

But even after copying /etc/pulse/ to /home/lube/.config/pulse/daemon.conf (not deleting the old file) i still have the stereo repeat.

Any other ideas?

I am not aware of any ‘stereo repeat’ function available in VLC or Linux

VLC can be configured to use either PulseAudio, JACK or ALSA

VLC advanced settings allow ALSA to be configured to use only the 5.1 channels instead of 8 channels for 7.1 surround

If VLC audio is playing to PulseAudio the audio stream can be inspected with this command

pactl list sink-inputs

If VLC is playing to either PulseAudio or JACK a user would be able to see the audio connections in JACK patchbay and could disconnect the 2 of 8 channels not required for 5.1 audio

Cadence and QjackCtl have options in settings to fix the number of audio i/o channels used by JACK. JACK start command can use additional options -i, --inchannels and -o, --outchannels to specify 6 channels instead of the 8 channels detected automatically

PulseAudio and JACK already are configured and JACK is connecting with a 7.1 input. And I don’t want to reduce the inputs. I just want to disable the otherwise known as “upmix” or “remix” feature in pulseaudio. ALSA and JACK work perfectly.

I’ll change the title from

Is it possible to deactivate the “stereo repeat” option?


How to deactivate 7.1 upmix for stereo sources

I suggest you check PulseAudio configuration options with this command

pulseaudio --dumpconf

There are probably only 2 configuration changes needed to disable PulseAudio from using all channels for remixing and allow LFE remixing for the sub-woofer channel

This command will create a PulseAudio daemon configuration file in $USER home folder with the 2 configuration changes

cat <<EOT > ~/.config/pulse/daemon.conf
remixing-use-all-sink-channels = 0
remixing-produce-lfe = 1

Use this command to restart PulseAudio with the new deamon configuration (or reboot system)

systemctl --user restart pulseaudio

See PulseAudio manpage man pulse-daemon.conf for more information about daemon configuration options
pulse-daemon.conf(5) — Arch manual pages

You might also want to consider this suggestion to remap the 7.1 surround channels in PulseAudio to independent sink outputs for 5.1 surround and 2.0 stereo
PulseAudio/Examples - Splitting 7.1 into 5.1+2.0 | ArchWiki

Thanks for the suggestion, but sadly nothing worked. Even after doing

cat < ~/.config/pulse/daemon.conf
remixing-use-all-sink-channels = 0
remixing-produce-lfe = 1

The output of

pulseaudio --dump-conf

still was the same with

enable-remixing = yes
remixing-use-all-sink-channels = yes

I suggest you reboot system and check pulseaudio --dump-conf again
The first line in the response Read from configuration file: should confirm the configuration is from User home folder instead of default system folder /etc/pulse/daemon.conf

If the system default configuration is still in use, check the new configuration file in a text editor

nano ~/.config/pulse/daemon.conf

Considering the manpage comment for enable-remixing= option, I do not think it is prudent to be changing that configuration option

There is no known valid use case for setting this option to no, therefore, this option is deprecated and may be removed in a future version of PulseAudio.

Thanks for the help!
The first line said this:

Aus Konfigurationsdatei wird gelesen: /home/lube/.pulse//daemon.conf

That just means

Reading out of Configuration File: /home/lube/.pulse//daemon.conf

And after changing that configuration file to disable the stereo repeat option and restarting pulseaudio it FINALLY workes!

Thanks to @fredvej and @nikgnomic for the great answers and helping me through this! (I am new to linux and i am learning every second!)