Is it possible to bypass a directory using org.gtk.vfs.UDisks2VolumeMonitor?

Hi.

I’m using a mount point at fstab with sshfs. Something like →

user@xxx.217.xx.105:/home/user /home/user/Development/db0.mountpoint.com fuse.sshfs noauto,x-systemd.automount,_netdev,users,idmap=user,IdentityFile=/home/user/.ssh/id_rsa/ubuntu-mountpoint.pub,allow_other,reconnect,port=50022,compression=yes,default_permissions,uid=1000,gid=1000 0 0

So this line at fstab will mount/umount with autodemand a remote dir into my local filesystem at → /home/user/Development/db0.mountpoint.com

All ok, thunar Ok, but when I don’t have internet connection there are many delays, even “Desktop” and Thunar have temporary stalls.

With the command:
xfdesktop-settings -e

I saw this: →

(xfdesktop-settings:3242): Gtk-WARNING **: 11:21:35.857: Content added to the action area of a dialog using header bars

(xfdesktop-settings:3242): Gtk-WARNING **: 11:21:35.858: Content added to the action area of a dialog using header bars
DBG[xfdesktop-common.c:324] xfdesktop_debug_set(): debugging enabled
Error creating proxy: Error calling StartServiceByName for org.gtk.vfs.UDisks2VolumeMonitor: Failed to activate service ‘org.gtk.vfs.UDisks2VolumeMonitor’: timed out (service_start_timeout=120000ms) (g-dbus-error-quark, 20)

(xfdesktop-settings:3242): Gtk-WARNING **: 11:21:51.062: Failed to measure available space: Error getting filesystem info for /home/user/Development/db0.mountpoint.com: No such device

So the problem is that the " org.gtk.vfs.UDisks2VolumeMonitor" service is trying to measure the available space on a non-existent network mount point.

Is it possible to somehow tell this service not to try to measure a particular directory, a sort of blacklist or similar of directories to avoid ?

Thanks…

Hi, a temporary solution that I have found.

Reading info about here:
https://wiki.gnome.org/Projects/gvfs/doc

I defined the environment variable GVFS_REMOTE_VOLUME_MONITOR_IGNORE inside .xinitrc file (at my home directory) adding this line:

export GVFS_REMOTE_VOLUME_MONITOR_IGNORE=true

Now there is no error when I launch the command:

xfdesktop-settings -e

But I think there could be a more specific solution, only applicable to the mount point in the “/etc/fstab” file, maybe a similar parameter other parameters like:

x-gvfs-name
x-gvfs-icon
x-gvfs-symbolic-icon

But I have not been able to find a specific parameter that disables “gvfs-volume-monitor” for a mount point in fstab.

See information about this params here:
https://gitlab.gnome.org/GNOME/gvfs/raw/master/monitor/udisks2/what-is-shown.txt