Is it posible to install Shopify on Manjaro?

Hi everyone.

I need to develop using Shopify, and in the official documentation I don’t see the option to install on Arch.

There are only two packages available in aur:

  • aur/shopify-themekit-bin-noconflict
  • aur/shopify-themekit-bi

But there is no shopify. I hope it can be posible.
Can someone guide me with this?

According to their guide you can install Shopify from so at first install rubygems if you don’t have:

pamac install rubygems

then install Shopify itself:

gem install shopify-cli

Hi @Tomek

Will I be inconvenienced if I agree to install this?

At the end of the file this message appears:

What do you think?

No, why would you?

You should first update your mirror (because of the qt5 message)

Hi @mithrial

I updated my system with:

sudo pacman -Syu

and now, when I run the command

sudo pamac install rubygems

the following message is displayed:

Will this cause me problems when installing it? How are these types of conflicts resolved?

That packages are interdipendents, same happen with harfbuzz and freetype, is not an error, last line ask you to apply; don’t say there is a problem otherwise it would have failed

Ok, I’ll try accepting then. Thanks.

You still didn’t follow the advice to update your mirror list.

Hi @anon59284200.

Well, forgive my ignorance on the subject. Why is it necessary to update the mirror list?

I ran the command sudo pacman -Syyu to update the mirror list, That’s right?

sudo pacman-mirrors -g -f 5

And then do a sudo pacman -Syyuu

Your installed version of python-qt5 is newer than the ones on the repos, do either you installed it manually or there was n official downgrade. You should run above command to sync your installation to the repos.

1 Like

For whatever reason your python-pyqt5 is newer than what’s in the repository. Sometimes a package is reverted because some users have issues but otherwise it may be harmless to remain on the newer version. If you experience bugs then reinstall the package, it’ll downgrade to the one available in the repository.

@mithrial I run that command:

I’m in the same situation.

What situation? And please don’t post screenshots.

1 Like

Sorry I will not post more screenshots. The situation is that these conflicts appear to me and I don’t know if they will generate problems or not if I accept to install. As you can see, the default option recommended in the terminal is to not accept.

There are no conflicts - only warnings.

1 Like

Well, I ran the command:

pamac install rubygems

no problem. But when I run the command:

gem install shopify-cli

this message appears:

zsh: correct 'gem' to '_gem' [nyae]? 

I think gem is not installed.

It’s an autocorrect feature of your shell (zsh)

It’s trying to assist you when you might have made a typo and make it easy to correct it.

Not really helpful in this case - since you didn’t make a typo, but actually meant what you typed.
choose [n]o - to not correct it …

1 Like

I ran the commands:

pamac install rubygems


pamac install rubygems

as @Tomek said and shopify-cli was installed successfully. But when running the command:

shopify version

as it says in the official guide, it says that the shopify command is not recognized.

I can see this Warning in the terminal:

Fetching ast-2.4.2.gem
Fetching parser-
Fetching nokogiri-1.13.3-x86_64-linux.gem
Fetching liquid-5.1.0.gem
Fetching theme-check-1.9.2.gem
Fetching ffi-1.15.5.gem
Fetching rb-inotify-0.10.1.gem
Fetching rb-fsevent-0.11.1.gem
Fetching shopify-cli-2.12.0.gem
Fetching listen-3.7.1.gem
Fetching concurrent-ruby-1.1.9.gem
Fetching bugsnag-6.24.2.gem
WARNING:  You don't have /home/etcheverry/.local/share/gem/ruby/3.0.0/bin in your PATH,
	  gem executables will not run.
Successfully installed ast-2.4.2
Successfully installed parser-
Successfully installed nokogiri-1.13.3-x86_64-linux
Successfully installed liquid-5.1.0
Successfully installed theme-check-1.9.2
Building native extensions. This could take a while...
Successfully installed ffi-1.15.5
Successfully installed rb-inotify-0.10.1
Successfully installed rb-fsevent-0.11.1
Successfully installed listen-3.7.1
Successfully installed concurrent-ruby-1.1.9
Successfully installed bugsnag-6.24.2
Successfully installed shopify-cli-2.12.0
12 gems installed