Is anyone able to get Onionshare working?

I came across someone asking for help that they couldn’t Onionshare to work; the app wouldn’t launch.

I decided to see if I could corroborate their story, and I can’t get the app to launch.

Does anyone know the fix? Its an incredibly useful app and would be a shame if wouldn’t work on Manjaro

Onionshare is a great filesharing app that I recently discovered; however its not launching in Manjaro.

If I lcick on the icon, nothing happens.

CAn someone help me diagnose this issue?

It appears flatpak or snap is the preferred runtime environment.

Please read the documentation

  1. Install flatpak
    sudo pacman -Syu flatpak
  2. Download the file flatpakref file from
  3. Run
    flatpak install org.onionshare.OnionShare.flatpakref
  4. Launch OnionShare from your system menu


You can install using the --user argument to the python installer (no sudo required) but you don’t get the chatserver function

pip install --user onionshare-cli

Thank you very much, that worked!

I have two follow up questions if you don’t mind

1.) I like Pamac and opted to first enable flatpaks in there and see if I could use it to install oninoshare. But it couldn’t even find it using the search function. Even after I downloaded teh flatpakref file, it still couldn’t find it.

Do you have any idea why that could be? I just ofund it weird to use the command line since pamac has worked so well for me.

2.) If the repository version has an issue, why even include it in the official repositories? By the same token, shouldn’t the AUR version at least work?

It just has users like me go down a rabbit hole thinking somethign should work when it doesn’t.

Anyway, thank you again! It works.

I have no idea - I don’t use advanced functionality in Pamac

I don’t know.

The package in the repo is packaged by Arch and the package has been flagged out-of-date since late february - Arch Linux - onionshare 2.2-5 (any) - probably why the repo package doesn’t work - and most likely also why the AUR package doesn’t work.

It is often useful to look at the upstream documentation - checking what they recommend - and how they recommend installation.

The Arch package is outdated - the current upstream version is 2.3.2.

I tested the Arch PKGBUILD - changed the version and updated the checksums. It fails to build using the current source - revealing a new upstream file structure and new dependencies.

My guess is the upstream maintainer currently doesn’t have time to rework the script, has found Arch dependency issues, whatever or simply forgotten it.

Flatpak is a very good way of creating a unified runtime environment - maybe the upstream onionshare developer is preferring that distribution method - who knows.


Thanks for the information…I guess I’m just a little “shaken,” it’s teh first time the AUR hasn’t worked.

I was alwasy confused why Manjaro would even bother with flatpaks, because it had the AUR.

I guess this instance is an example of why it is a good idea.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.