iPhone WIFI hotspot drops every 15 min or so

I used to always tether my iPhone for internet access on the go, however since the ios 14 update that stopped working. This is being dealt with by the community;
github iphone tethering issue

Since USB tethering was not working ive had to resort to wifi hotspot instead. This connects just fine and works fine for approx 10-20 min. Then the connection drops and i have to toggle wifi hotspot on the phone to get it to re-connect.

I imagine it’s most likely the iPhone thats playing up. But iPhone support for Linux desktop users is somewhat lacking.

I suspect that the iphone is not detecting that the hotspot is being used, so is cutting it off, to save power, etc. However i wouldnt know where to begin with proving this.

Has anyone else had this issue?

Any help is appreciated.

So, on hitting save on the question, it occurred to me to try connecting another device to the hotspot at the same time to try force the connection to stay open.

The result was that the Manjaro laptop lost its connection. and the other device maintained its connection to the hotspot. so perhaps its not the iPhone after all.

Check TLP settings for that wifi card, or the USB port if is one of those models … Use tlpui package from repository and disable power saving for that device. For iPhone issues better ask the proper channels.

tested connection to an android phone over wifi hotspot without issue. tried with another iphone and still have the same issue.

Hi and welcome to the forum :+1:

If it works without issues for Android devices but not iPhone’s then the problem is obviously with the settings of the iPhone’s, agree?
Since in that case it is not related to Manjaro/Linux in general i have to agree with:

Meaning iPhone specific communities and/or support.
It has nothing to do with the connecting party (Linux) in this case…

PS, I just got an idea for you to try:
Try to run a ping in the background to force network traffic to keep the connection in “used” state, and see if that helps…
(Ofcourse this will use data of your iPhone)

import requests
import time

while True:
        response = requests.get('http://google.com')
        if response.status_code == requests.codes.ok:
    except Exception as e:
        print("NO INTERNET")

Thanks for the idea. Now Running this script to see what happens.

No idea in what language this code is in, but requesting the whole page will “eat” more data as just a normal ping packet :wink:

python, cheers for heads up.

import requests
import time
import datetime
from ping3 import ping, verbose_ping

ping.EXCEPTIONS = True  # Default is False.

while True:
        ping("http://google.com", timeout=10)
        print(str(datetime.datetime.now()) + " ALIVE")
    except Exception as e:
        print(str(datetime.datetime.now()) + " NO INTERNET")

revised script :wink:

1 Like

I know that if I share my internet connection via my Work iPad it will get “disabled” after some time without any traffic. Presumably to save battery power.

I did wonder if that was the case. I tried keeping a simultaneous connection to another device (android phone) and the laptops connection died, but the phones did not. There could be traffic on the phone keeping the connection alive.
My ping script failed to keep the connection active.
Reverting to sending a GET request to my own site that delivers only a string of text as its payoad. See if that works.

even with sending a GET request every 20s the connection dies.

A friend using ubuntu has found the same issue. so not a manjaro specific issue.

Did you solved the problem?
I have the same problem connection.
After some minutes the connection is dropped and I have to turn off Personal Hotspot from iPhone and turn on again.

I have noticed that it does not happen when the iPhone is connected with the powercord.
I think is a setting for saving battery of the iPhone.
If you have news for disabling this feature let me know.

@dlynfox, You should mention the name of the person you are asking, using @, so they get a notification else they won’t notice…
I will do for you this time to show: @Benny_H88

1 Like

Well… looks like USB tethering is now fixed! Fantastic!

WiFi hotspot still drops though.

Hope that I can help you. Maybe you need to wait for a software updating to fix this issue.
Or you should keep your Linux or iPhone working, ask Apple Support for help is a nice method, too.
Sometime a iOS system recovery tool like TunesKit also works well.