Invalid or corrupt updates

Fresh install, all went well , response after downloading 855mg update was “Invalid or corrupt package”

Could use some help thanks.

Welcome to the forum!

Try refreshing your mirrors. :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

Be sure to let the command finish and do not interrupt the process. :wink:


I am having the same problem so I tried your advice. Unfortunately after going through the whole thing, After downloading 900 package updates and installing them and then the dozens of keys to check them. I then had to go through hundreds of keys and packages that said “file corrupt delete Y or N” and after all that time consuming aggravation I got a message that said “file corrupt 0 packages installed” and now I am back to needing 900 updates.

try these commands:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

ignore any errors, when done refreshing, rerun update again

Having same issue, tried earlier advice it failed. I seen your solution here and tried that, after going through that process I decided instead of waiting through all 900 upgrade files to maybe see it fail again I would try to update just Konsole. Now I get a new error screen window - Failure to commit transaction - "conflicting files:

  • libxcrypt-compat: /usr/lib/ already exists in filesystem (owned by glibc)
  • lib32-libxcrypt-compat: /usr/lib32/ already exists in filesystem (owned by lib32-glibc)"
    I tried 2 other files with the same results.

so if the refreshing didtn worked, and you still had keyring issues, open this file:
kate /etc/pacman.conf and edit this line:
SigLevel = Required DatabaseOptional - its on the 45 line
to look like this:
SigLevel = Optional TrustAll
Save it and run update again.

@brahma This is not a nice option to just disable all security.

You could run it with pamac update --force-refresh --overwrite "*"

1 Like

yes i know its not a good option, but if the usual commands not work, this is what remains …
never seen that command of yours being used in this case; do you have any experience running it on these keyring errors?

No, of course it doesn’t help with the keyring issue but with the “file exists in filesystem” error.

The keyring should be fixed with the first of your commands:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro

I would recommend against updating the keys from the public keyservers. All required keys are in the keyring packages.
They could be reinstalled:

pamac reinstall archlinux-keyring manjaro-keyring
1 Like

THANKS! This worked for me and updated all of the now 927 updates needed by my computer. If only I could get it to dual properly without me having to go into F3 - bios recovery to see the dual boot screen.
Thanks again for this tip!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.