Interrupted update - Manjaro doesn't boot anymore

Hey guys,

I interrupted an update (bad idea, I know that now) and since Manjaro doesn’t boot anymore.

With the guides I was able to find I started a Live Iso from a USB and chrooted into my installed system. I removed the locking of the database so that I can run pacman again:
# rm /var/lib/pacman/db.lck
That changed the error, now it seems that pacman can’t connect to a mirror.

Using # pacman -Syyu yields error messages like the following

:: Synchronizing package databases...
error: failed retrieving file 'core.db' from : Could not resolve host:
[same error for a lot of other mirrors]
error: failed to update core (invalid url for server)
[same errors also for extra, community and multilib]
error: failed to synchronize all databases

I get the same errors when using pacman -Syyu linux54 which was suggested in another post.

Also when I use pacman-mirrors I get

Pacman-mirrors version 4.19.1
::Downloading status failed!
::Please check you network connection ...

I can write this post in the forum though and I can also ping through the terminal, so I think the connection is not the problem.

Any ideas on how to fix this?

The underlying problem is similar to Manjaro boot error vmlinuz-5.8 not found (can’t link it) and in the thread running these commands is asked for:

mhwd-kernel -li
mhwd -li
ls /etc/mkinitcpio.d/*.preset
Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
   * linux54
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
ls: cannot access '/etc/mkinitcpio.d/*preset': No such file or directory

I think you need to cp /etc/resolv.conf /chroot/etc/

Change path to wherever you mounted the chroot

For more details see:

1 Like

Thank you NGr, case solved.

I stumbled over the thread you gave before but I thought using manjaro-chroot -a would do the same. Apparently it doesn’t. Just followed all the single steps and used pacman -Syyu again, this time it worked.

Thank you for taking care of noobs like me.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.