Internet not working via Ethernet on Manjaro PC

New to Linux, set up a custom PC running solely Manjaro a while ago. At first it worked fine on our slow internet and displayed the “limited connectivity” warning, but it worked nonetheless. A few months ago, it stopped being able to make a solid connection to the internet altogether. It can still connect to my wifi network or Ethernet connection, but cannot load anything on any web browser and every ping I send from the konsole fails. The web browsers say they cannot find the server or that the DNS address can’t be found. I’ve found some similar issues in threads across this site, but none of the offered solutions have worked. This includes replacing my Ethernet cord, restarting Network Manager, phone hotspot, reconfiguring r8169, disabling ipv6, and a few other simple fix possibilities. If anyone has any ideas to further troubleshoot or is familiar with this problem at all please let me know!

Perhaps that is actually true - the DNS that your router gets from your provider, and which is then used by your PC, may not function, or not reliably.

Try setting a custom nameserver like or in the NetworkManager settings
To do that, go to IPv4 settings for the connection
and change the method from “automatic (DHCP)”
to “automatic (DHCP), Addresses only”
and enter a custom nameserver in the field
“additional DNS servers” below.

You could just as well leave that setting as it is
and set the custom nameserver in your router - but I cannot tell you how because each user interface is different and model specific.

The point is not to use the DNS server that your provider assigns you
and see whether that quick intervention changes anything.

I have never seen the “limited connectivity” warning that you mention - and don’t know what that actually means or where this message would come from.

Try searching for r8169 or r8168 - there’s a quadrillion topics on that adapter.

Internet not working - hmm - difficult - you are vague - what is not working?

  • The device?
  • The driver?
  • The link?
  • The resolver?
  • The cable?
  • The connection?

The kernel driver r8169 is working with latest LTS kernel 5.15.25 (unstable).