Internet has become very slow after kernel update


My kernel updated before couple of days, and since then the network is very slow. Please help.

$ inxi -Fazy
  Kernel: 5.9.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=759188f8-86d1-4deb-aefe-36b0e1548d2b rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20L6S7V600 v: ThinkPad T480 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20L6S7V600 v: SDK0J40697 WIN serial: <filter> 
  UEFI: LENOVO v: N24ET59W (1.34 ) date: 06/02/2020 
  ID-1: BAT1 charge: 45.4 Wh condition: 45.4/47.5 Wh (96%) volts: 12.4/10.8 
  model: SANYO 01AV425 type: Li-ion serial: <filter> status: Unknown 
  cycles: 247 
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: E0 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-8:5 chip ID: 13d3:56a6 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1015x570mm (40.0x22.4") 
  s-diag: 1164mm (45.8") 
  Monitor-1: HDMI2 res: 3840x2160 hz: 30 dpi: 160 size: 610x350mm (24.0x13.8") 
  diag: 703mm (27.7") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.2 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo ThinkPad T480 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.10-1-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Lenovo ThinkPad T480 driver: e1000e 
  v: kernel port: efa0 bus ID: 00:1f.6 chip ID: 8086:15d8 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 
  bus ID: 03:00.0 chip ID: 8086:24fd 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: br-fa46bcd05aa7 state: up speed: 10000 Mbps duplex: unknown 
  mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
  IF-ID-3: veth3d5ca69 state: up speed: 10000 Mbps duplex: full mac: <filter> 
  IF-ID-4: veth57a8b1e state: up speed: 10000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 238.47 GiB used: 49.21 GiB (20.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Lexar model: 256GB SSD size: 238.47 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 117H 
  scheme: GPT 
  ID-1: / raw size: 164.76 GiB size: 161.17 GiB (97.82%) 
  used: 49.17 GiB (30.5%) fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 283 Uptime: 12m Memory: 23.26 GiB used: 2.65 GiB (11.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1348 pacman: 1337 
  lib: 370 flatpak: 4 snap: 7 Shell: Zsh v: 5.8 default: Bash v: 5.0.18 
  running in: emacs inxi: 3.1.08

I also tried changing to 5.8 and 5.7 kernel, but it did not work.

What do you mean by it did not work? If you could not switch the kernel how do you know the new updated kernel is the problem? Also if you meant that changing the kernel did not fix your slow internet problem, wouldn’t that mean it’s not a problem with the kernel?

Whenever I have a slow internet problem I follow this process. I check other web browsers to see if it is a problem with my browser. Then I check other devices on the same network to see if it is a network problem. If I find it is a problem with my computer I will try switching kernel, I will download the CLI tool and test the internet speed outside a browser. That is just my process I use to find my internet problems which normally works for me. Hope this helps.

@jaden thanks for the suggestions.

  1. I meant switching to 5.8 and 5.7 did not resolve the slow internet issue.

  2. My assumption is that the kernel/driver update is the cause, as that was the only change that I can think off. Now reverting to the other installed ones did not resolve it, I am going to try 5.4 and see if that makes a difference.

  3. My other devices using the same wifi connection work well. It is only the manjaro box which has the issues.

  4. The slow internet issue is intermittent, when I restart the machine or reconnect to the wifi the internet works normally for some 5-10 minutes and then again starts crawling. Sometimes the internet will become very slow, sometimes it will just stop working. At times restarting resolves it, at times it doesnt do anything. sorry for the vague answer.

  5. ping also starts failing so its not just a browser issue.

this is my ip a output

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether e8:6a:64:bb:93:98 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether a6:3a:01:d0:df:0e brd ff:ff:ff:ff:ff:ff permaddr d4:3b:04:d4:a8:f0
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
link/ether 02:42:a7:56:4f:2a brd ff:ff:ff:ff:ff:ff
inet brd scope global docker0
   valid_lft forever preferred_lft forever
5: br-fa46bcd05aa7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
link/ether 02:42:43:6c:8b:df brd ff:ff:ff:ff:ff:ff
inet brd scope global br-fa46bcd05aa7
   valid_lft forever preferred_lft forever
inet6 fe80::42:43ff:fe6c:8bdf/64 scope link noprefixroute 
   valid_lft forever preferred_lft forever
7: vethf498503@if6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-fa46bcd05aa7 state UP group default 
link/ether 76:36:4f:28:84:a3 brd ff:ff:ff:ff:ff:ff link-netnsid 0
inet6 fe80::7436:4fff:fe28:84a3/64 scope link 
   valid_lft forever preferred_lft forever
9: vethc2f0c96@if8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-fa46bcd05aa7 state UP group default 
link/ether f6:dc:a1:97:56:d8 brd ff:ff:ff:ff:ff:ff link-netnsid 1
inet6 fe80::f4dc:a1ff:fe97:56d8/64 scope link 
   valid_lft forever preferred_lft forever

I am not sure is some of the above interfaces should be removed etc

below is the output from ping when it had become very slow -

ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

Its not a kernel problem because faced similar issues with 5.4 too.

I did some research and I think that you are exceeding a system parameter at /proc/sys/net/core/wmem_max . You can change it with the following command.

Make sure you are logged in as root with sudo su or su
Then run,
# echo 83886080 > /proc/sys/net/core/wmem_max
I think you are right about it being a problem with updated drivers if this parameter was changed.

I also have a VERyslow wifi with the same wificard and driver
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi

For me it works fine when i boot of a manjaro-iso. Then the wifi works as expected

I tried this but after a reboot the value is reset to 212992.

I changed my connection:
IPv4 settings - Method: Automatic (DHCP) addresses only
IPv6 settings - Method: Automatic, addresses only
and my Youtube now loads faster than before. Of course, the first run loads slower but when you search or reload it loads faster compared to the default settings.