Internet doesn't work in specific router

My laptop connects to other wifi routers and everything works, but if I connect to my home router it doesn’t work. I tried to connect to router by cable that goes through router, still doesn’t work. If I directly connect the internet to the computer without a router, it works. If I connect to wifi with my phone and share wifi to laptop it works.
If I boot from usb wifi works.

Obviously this is an issue with your router.

We can’t help you troubleshoot your router … :man_shrugging:

but router doesn’t work only on my laptop, with other devices it works

Since your Manjaro Linux system work as expected with other routers - it is obviously your home router which does not accept your Manjaro Linux system.

Why it is so? I have no idea and it is impossible to guess.

1 Like

I booted manjaro from usb and wifi worked, so I think problem is my settings

next step: create another user, log in as this new (test)-user. does it work ? in this case it would be something with your personal config files of the origin user, otherwise it’s something related to general settings.

I created new user and tried, it doesn’t work

did you edit any config files like /etc/resolv.conf or others in the past ? are you using any vpn or other things that you still not posted here ?

No, i didn’t change anything

Possible helpful info you can provide

Output (as text - not screenshot) from

cat /etc/resolv.conf


nmcli -t device show

okay take a live-iso and boot to the live system. connect to the internet with this iso. does it work ?

#Generated by NetworkManager

second one is too long: link to file content

Yes it works

You should always paste terminal output inside a code fence like this

output from cat /etc/resolv.conf

Thus you would have been able to paste the complete outpu but a pastebin is equally good.


You have a lot of containers running on bridged interfaces …

I see your primary wlan interface

GENERAL.STATE:100 (connected)
IP4.ROUTE[1]:dst =, nh =, mt = 600
IP4.ROUTE[2]:dst =, nh =, mt = 20600
IP6.ROUTE[1]:dst = fe80::/64, nh = ::, mt = 1024 

Then you have a bridge using the same ip range but with a different subnet

GENERAL.STATE:100 (connected (externally))
IP4.ROUTE[1]:dst =, nh =, mt = 0

And that could be your problem

One cannot and should not advise what to do or not do to solve this - it is simply not possible when one does not know the purpose of everything else - you on the other hand is supposed to know everything about this.


if you didn’t all the editing of the config file then who did it ? in this case i recommend that you ask the person who did all the settings !

btw. this is another topic where users claim they don’t know what happened, they did no changes and in the end we get a mess presented that the user expects to get solved by us. sorry but if you didn’t edited these configs, what i really trust, then ask the guy who did it not to get in trouble with him because “we” supposed to do so.

how can I remove that bridge? I really do not understand networks. I use docker for web development and it created containers

I have no idea - you are on your own with that.

One possible avenue could be to remove containers you don’t actually use.

ok, thanks

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.