Internal USB bus devices disappear after wake from suspend

I am using a Thinkpad X1 Carbon (4th gen) with the 5.11 kernel and Cinnamon DE, and I’ve recently noticed an issue with suspend and wake.

When I boot up the laptop and run lsusb, I get the following output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 138a:0090 Validity Sensors, Inc. VFS7500 Touch Fingerprint Sensor
Bus 001 Device 003: ID 13d3:5248 IMC Networks Integrated Camera
Bus 001 Device 002: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However, if I put the laptop to sleep and then wake it up later, it will often fail to find the Bluetooth adapter and the webcam. If I run lsusb while this problem is occurring, I get the following output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It might be to do with the kernel version I am using, so I’ve switched to 5.4 LTS for a few days to see if the issue occurs again. I also had some problems with my Bluetooth mouse timing out too frequently due to the way I had TLP configured, so I blacklisted the auto-suspend of the entire Bluetooth controller and made a few other configuration changes to address that - it could have led to this suspend problem, but I’m not sure as I don’t know when the ‘USB devices disappearing’ phenomenon started. Similarly, I switched to pulseaudio-modules-bt to get LDAC working with my wireless headphones, I think before this issue began, but again, I don’t know if they’re linked because the fingerprint reader and webcam are also both disappearing from lsusb output after wake from suspend, so it isn’t just the Bluetooth adapter.

I also had a look with journalctl but couldn’t see anything that identified or explained this issue. I’ve copied the log for the last two boots and the last two suspend/wake cycles in case anyone wants to have a look:

Can anyone suggest how I can begin troubleshooting this? Thank you!!

  • Does this happen on other kernels too? (5.4 and 5.10 would be indeed my first choice.)
  • Your log seems to indicate your system is hibernating, not suspending. have you tried suspending without hibernating? Is the symptom the same on both?
  • So have you tried reverting that change yet?


I have the same problem on my Asus Vivobook X512D. All USB devices disappear leaving only the root hubs visible to lsusb just like on yours. It can occur for me after resuming from suspend or even randomly when not suspended. Tends to occur on battery and less often when plugged in. I don’t have TLP installed. Kernels 5.4, 5.10 and 5.11 rc7 all have the same issue.

I am trying to disable suspending USB devices to see if that helps. I ran

sudo gedit /etc/default/grub

I added usbcore.autosuspend=-1 to GRUB_CMDLINE_LINUX_DEFAULT=

Then ran

sudo update-grub

And on reboot, the webcam is behaving so far.


So far so good. The usbcore.autosuspend=-1 kernel parameter works for me.

Does it work for you as well?

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.