Internal speaker does not play audio on Huawei Matebook 14S

I recently bought a 2023 Huawei Matebook 14S and installed both Manjaro and Windows 11 on it. While most things are working fine on Manjaro, I’ve just discovered that the built-in speaker does not work properly on Manjaro Linux while on Windows it is working just fine.

When I check the pavucontrol configurations, there are two options available: 'Play HiFi Quality Music' and 'Pro Audio', none of which would play sound.

What’s more, headphones plugged in with audio jack also play perfectly.

Output for aplay -l:

lspci -nn | grep audio                                                                 
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Raptor Lake-P/U/H cAVS [8086:51ca] (rev 01)

Output of inxi -A:

  Device-1: Intel Raptor Lake-P/U/H cAVS driver: sof-audio-pci-intel-tgl
  API: ALSA v: k6.6.1-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 0.3.84 status: active

Output of dmesg | grep -E ‘sof|snd’:

[    0.048286] software IO TLB: area num 32.
[    1.022154] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    1.022155] software IO TLB: mapped [mem 0x00000000311ac000-0x00000000351ac000] (64MB)
[    4.158447] sof-audio-pci-intel-tgl 0000:00:1f.3: enabling device (0000 -> 0002)
[    4.158684] sof-audio-pci-intel-tgl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[    6.019751] sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    6.092386] sof-audio-pci-intel-tgl 0000:00:1f.3: use msi interrupt mode
[    6.131493] sof-audio-pci-intel-tgl 0000:00:1f.3: hda codecs found, mask 5
[    6.131497] sof-audio-pci-intel-tgl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    6.131501] sof-audio-pci-intel-tgl 0000:00:1f.3: DMICs detected in NHLT tables: 4
[    6.135881] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
[    6.135886] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
[    6.135892] sof-audio-pci-intel-tgl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
[    6.250404] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
[    6.250411] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
[    6.268461] sof-audio-pci-intel-tgl 0000:00:1f.3: Topology: ABI 3:22:1 Kernel ABI 3:23:0
[    6.323958] input: sof-hda-dsp Mic as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input16
[    6.324070] input: sof-hda-dsp Headphone as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input17
[    6.324164] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input18
[    6.324260] input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input19
[    6.324340] input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input20

i have tried replacing my kernel with the latest linux66 as is suggested [here]( but the audio is yet still not working…

When you say built-in speaker does not work properly on Manjaro; what is the exact problem - no sound?

There is a long github issue that might be relevant:

script claims to toggle speaker/headphones output

thnkas buddy, i can confirm the commands

sudo hda-verb /dev/snd/hwC0D0 0x16 0x701 0x0001 // move output to speaker dac
sudo hda-verb /dev/snd/hwC0D0 0x17 0x70C 0x0002 // enable speaker
sudo hda-verb /dev/snd/hwC0D0 0x1 0x715 0x2     // disable headphones

solve the issue on manjaro and fedora linux.

1 Like

Try this solution: GitHub - Smoren/huawei-ubuntu-sound-fix: Fix for sound card behavior on Huawei Matebook s14 / s16 on Ubuntu 22.04 / Fedora / Arch
It works as a daemon and manage the sound card on phones connect/disconnect.