Internal Microphone doesnt work after (pulseaudio-asla, systemd, kernel) update

Hello there,

I run Manjaro (KDE, Kernel 5.12), on a ThinkPad T14 (AMD).
After an update yesterday my internal Microphone doesn’t get recognized by the system (Systemsettings or any program). The speakers still work fine.
Since I am pretty new to linux, I am not sure what the problem exactly? (udev, pulseaudio, kernel)
Pulseaudio, kernel and some systemd stuff got update.
I tried to boot an older kernel without success.
If you need some further information let me know.
Would highly appreciate if someone could help me.
Thank you very much!

uname -r

ps ax | grep pulse
1748 ? S<sl 0:13 /usr/bin/pulseaudio --daemonize=no --log-target=journal
1945 ? Sl 0:00 /usr/lib/pulse/gsettings-helper
6515 pts/1 S+ 0:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn --exclude-dir=.idea --exclude-dir=.tox pulse

pacmd list-sources
1 source(s) available.

  • index: 0
    name: <alsa_output.pci-0000_07_00.6.analog-stereo.monitor>
    driver: <module-alsa-card.c>
    state: RUNNING
    suspend cause: (none)
    priority: 1030
    volume: front-left: 65536 / 100% / 0,00 dB, front-right: 65536 / 100% / 0,00 dB
    balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 0,00 ms
    max rewind: 6 KiB
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
    used by: 1
    linked by: 1
    configured latency: 40,00 ms; range is 0,50 … 1999,82 ms
    monitor_of: 0
    card: 1 <alsa_card.pci-0000_07_00.6>
    module: 8
    device.description = “Monitor of Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo”
    device.class = “monitor”
    alsa.card = “1”
    alsa.card_name = “HD-Audio Generic”
    alsa.long_card_name = “HD-Audio Generic at 0xfd3c0000 irq 109”
    alsa.driver_name = “snd_hda_intel”
    device.bus_path = “pci-0000:07:00.6”
    sysfs.path = “/devices/pci0000:00/0000:00:08.1/0000:07:00.6/sound/card1”
    device.bus = “pci” = “1022” = “Advanced Micro Devices, Inc. [AMD]” = “15e3” = “Family 17h (Models 10h-1fh) HD Audio Controller”
    device.string = “1”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card-pci”

tail -n1000 /var/log/pacman.log | grep pulse
[2021-06-15T09:39:04+0200] [ALPM] removed lib32-libcanberra-pulse (0.30+2+gc0620e4-3)
[2021-06-15T09:39:04+0200] [ALPM] removed libcanberra-pulse (0.30+2+gc0620e4-3)
[2021-06-15T09:39:07+0200] [ALPM-SCRIPTLET] WARNING: Non-backwards compatible changes to ALSA require restarting of audio engines (e.g. pulseaudio or pipewire) using it.
[2021-06-15T09:39:54+0200] [ALPM] upgraded pulseaudio-alsa (1:1.2.2-2 → 1:1.2.5-2)

[2021-06-16T08:34:50+0200] [ALPM] upgraded systemd-libs (248.3-2 → 248.3-3)
[2021-06-16T08:34:51+0200] [ALPM] upgraded systemd (248.3-2 → 248.3-3)
[2021-06-16T08:34:52+0200] [ALPM] upgraded systemd-sysvcompat (248.3-2 → 248.3-3)
[2021-06-16T08:34:52+0200] [ALPM] running ‘20-systemd-sysusers.hook’…
[2021-06-16T08:34:52+0200] [ALPM] running ‘30-systemd-catalog.hook’…
[2021-06-16T08:34:52+0200] [ALPM] running ‘30-systemd-daemon-reload.hook’…
[2021-06-16T08:34:53+0200] [ALPM] running ‘30-systemd-hwdb.hook’…
[2021-06-16T08:34:53+0200] [ALPM] running ‘30-systemd-sysctl.hook’…
[2021-06-16T08:34:53+0200] [ALPM] running ‘30-systemd-tmpfiles.hook’…
[2021-06-16T08:34:53+0200] [ALPM] running ‘30-systemd-udev-reload.hook’…
[2021-06-16T08:34:53+0200] [ALPM] running ‘30-systemd-update.hook’…
[2021-06-16T12:50:47+0200] [ALPM] running ‘30-systemd-daemon-reload.hook’…
[2021-06-16T12:50:48+0200] [ALPM] running ‘30-systemd-udev-reload.hook’…
[2021-06-16T12:50:48+0200] [ALPM] running ‘30-systemd-update.hook’…
[2021-06-16T13:07:04+0200] [ALPM] running ‘30-systemd-update.hook’…
[2021-06-16T13:35:47+0200] [PACMAN] Running ‘pacman -S systemd’
[2021-06-16T13:36:27+0200] [PACMAN] Running ‘pacman -S systemd-248.3-2’
[2021-06-16T13:36:47+0200] [PACMAN] Running ‘pacman -S systemd-248.3-1’
[2021-06-16T13:36:50+0200] [PACMAN] Running ‘pacman -S systemd-248.3’
[2021-06-16T13:38:32+0200] [PACMAN] Running ‘pacman -S systemd-248.3-2’
[2021-06-16T13:38:38+0200] [PACMAN] Running ‘pacman -S systemd’

[2021-06-15T09:39:04+0200] [ALPM] upgraded util-linux-libs (2.36.2-1 → 2.37-3)
[2021-06-15T09:39:06+0200] [ALPM] upgraded util-linux (2.36.2-1 → 2.37-3)
[2021-06-15T09:39:11+0200] [ALPM] upgraded lib32-util-linux (2.36.2-1 → 2.37-1)
[2021-06-15T09:39:17+0200] [ALPM] upgraded linux510 (5.10.41-1 → 5.10.42-1)
[2021-06-15T09:39:23+0200] [ALPM] upgraded linux510-headers (5.10.41-1 → 5.10.42-1)
[2021-06-15T09:39:23+0200] [ALPM] upgraded linux510-virtualbox-host-modules (6.1.22-11 → 6.1.22-12)
[2021-06-15T09:39:36+0200] [ALPM] upgraded linux512 (5.12.8-1 → 5.12.9-1)
[2021-06-15T09:39:42+0200] [ALPM] upgraded linux512-headers (5.12.8-1 → 5.12.9-1)
[2021-06-15T09:39:42+0200] [ALPM] upgraded linux512-virtualbox-host-modules (6.1.22-12 → 6.1.22-13)

Same issue here. Head phone not working after lately update.

Me too - ideapad 5 14ARE05 with Ryzen 5 4600U.

Pretty annoying, went into an important online meeting today without a microphone…
Luckily I had some bluetooth earbus close which I could use as a backup mic.

Have tested 5.11 and 5.10 kernels without luck - 5.11 is still at 5.11.6 due to another issue I’m facing, so it has not been updated recently. Therefore it’s unlikely to be a kernel issue.

Fixed it, with updating to testing repo :smiley: so should be an issue with a pulseaudio lib. Not sure tho.

1 Like

Ah, so maybe I’ll try this then. Has the added benefit that I get to test Plasma 5.22. Who needs stability? :grin:

Same issue here, but with Pipewire. The testing update fixed it for me, too.

As we all seem to be on Ryzen, perhaps it’s a firmware issue. Doesn’t really matter though, as long as its fixed :slight_smile: