IntelliJ IDEA crashes with xorg-xwayland 23.2.5-0

Recent few days, I’ve been experiencing xwayland crashes. It appears to happen every time I open the layout view in Intellij (a Java program for Android app development). I had never had the problem in the past. I checked my update history of packages on Pamac, and it turns out xorg-xwayland was updated on April 5: upgraded xorg-xwayland (23.2.4-2 → 23.2.5-0).

I just reverted back to 23.2.4-2, and things appear stable.

Difficult to provide a meaningful response.

What is the layout view - is it some kind of UI drag’n’drop composer?

Is your IntelliJ installed from the repo or using JetBrains toolbox?
Using JetBrains toolbox delivers updates to your IntelliJ app faster than the repo.

Is you IntelliJ app up-to-date?

Is the IntelliJ delivered as part of Android Studio?

I use JetBrains tools - albeit not Android development - on Plasma 6 with wayland session with 23.2.5-1 on edge Manjaro - I have experience no issues - so it is possibly related to the app itself and not the

the layout view shows in graphics the appearance of a layout. I attached a screenshot.

I downloaded community edition of Intellij from Jetbrains website. The problem happened with 2 versions of Intellij: 2023.3.5 and 2024.1. I use the former for quite some time and never had the problem until recently, and I upgraded to the latter two days ago and it has the problem in the same way as the former.

Intellij is delivered standalone, and Android Studio is based on Intellij, though on older versions.

When using Intellij for code editing, there appears no problem with the new version of xwayland, it only happens when the graphic view is opened (appears to me).

If someone want to test it out with a project, you can try my open-sourced Podcini: GitHub - XilinJia/Podcini: Open source podcast player for Android in Kotlin with androidx.media3

After reverting back xorg-xwayland, though it doesn’t crash, there appear some new phenomena. After the layout view is opened for a while, the code view in other tabs becomes blank (grayed out). I need to close the layout view to see the code in other tabs. This also didn’t happen before. Wonder if I need also to revert these all:

[2024-04-05T06:31:25+0000] [ALPM] upgraded xorg-server (21.1.11-1 → 21.1.12-0)
[2024-04-05T06:31:25+0000] [ALPM] upgraded xorg-server-common (21.1.11-1 → 21.1.12-0)
[2024-04-05T06:31:25+0000] [ALPM] upgraded mhwd-nvidia (550.54.14-2 → 550.67-1)

BTW, I’m running KDE wayland session, are xorg-server and xorg-server-common used at all during the session?

This is clearly an issue with the application under wayland.

I suggest you try if you can reproduce using Xorg session - then file a bugreport with JetBrains.

Now that I think of it - at some point Manjaro started to build the xorg-server - perhaps the maintainer knows more - listed in the package info as @Yochanan

How would you explain the fact that Intellij had worked fine with xorg-xwayland 23.2.4-2 (I had used for long time), and only started to have problem with 23.2.5-0?

Let’s wait for the maintainer to come online - he is in some US timezone - but it is possible that minor differences between the Manjaro xorg-server build and Arch Linux xorg-wayland builld could cause - but it may as well be the rapid changes which cause it.

I don’t - I am not the developer of xorg-wayland - so I have no idea.

From the version of xorg-xwayland you posted - you appear to be using stable branch - the xorg-wayland is at at 23.2.5-1 - it shouldn’t matter much though - just pkgrel bump - still upstream Arch Linux though.

I don’t now why xorg-server is packaged by Manjaro.

However - I do know that the rolling release model Arch Linux and Manjaro Linux can cause 3rd party software to misbave.

There is nothing to guarantee a 100% compatibility with 3rd party applications - that is a fact we all live with.

We only package xorg-server packages, not xorg-xwayland. However, we did fast-track XWayland 23.2.5 and X.Org Server 21.1.12 to all branches as they fixed a security issue.

I took the time to figure out how to get IntelliJ to produce the editor views you mention.

I have nil, nada, null experience with Android development so it would be sheer conincidence if I could reproduct your issue.

I cannot make IntelliJ crash - so it is possibly some inconsistency on your system.

I suggest you use what ever works for you - our systems are not equal.

My system

 $ pacman-mirrors -aG

 $ inxi -Sa
  Host: tiger Kernel: 6.6.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=07c78795-e8a4-4134-be2e-be5908c5b9f8 rw quiet splash nowatchdog
    udev.log_priority=3 mitigations=off amd_pstate=active
  Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
    wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Manjaro
    base: Arch Linux
1 Like
pacman-mirrors -aG

inxi -Sa
  Host: MacManj Kernel: 6.6.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=06f2f8c6-47ea-444a-97a1-44629f02874f rw quiet splash
    resume=UUID=0fc478b2-1d95-466e-bafd-6de6515a989b udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux

Sorry, I might have said something imprecise. Not every graphic view of layout causes xwayland and Intellij to crash.

I went to do my test again. I upgraded to 23.2.5-0, started Intellij, tested with a few layout files, found one that triggers the crash, noted the layout file. Then I downgraded xorg-xwayland to 23.2.4-2, restart the machine, started Intellij, opened the layout file, and it doesn’t crash. Then I upgraded to 23.2.5-0 again, opened the layout file, it crashes.

The crash is indeed xwayland because I first see a balloon with the message “xwayland crashed”, then Inteliij crashes. It’s a very bad experience because once it happens I have to logout and log back in to restart Intellij.

If you would test with my Podcini project (GitHub - XilinJia/Podcini: Open source podcast player for Android in Kotlin with androidx.media3), clone that project into a directory, then open the entire project with Intellij (howto: Open project - JetBrains Guide), once Intellij initializes, do full-project search (normally with key-binding: Ctrl-Shift-F) for “SpeedSelectDialogBinding”, open the Kotlin file that contains the word, then locate the word in the file, move the cursor onto the word, then press Ctrl-B, it then opens the layout file. There are three ways of showing the layout file, text only, text and graphic, and graphic only. Choose the text and graphic (I can’t say at the moment whether the other two also triggers crash), then you should see the balloon about xwayland crash and then Intelllij crash.

Technically I don’t see why this is an OS error - as you state - only one specific file triggers this.

Please note that this forum is about Manjaro Linux - the forum is not about troubleshooting and debugging your application code even if you run the editor on Manjaro LInux.

Coding issues is much better solved by talking to experts in the language at hand - perhaps using some of the stackexchange channels.

That said, I have personally experienced similar errors in other situations with other coding languages.

With the description provided - I think you have an error in your code - which causes the editor to crash when editing the specific file in a specific manner.

I can get my Wayland to crash as you described but I don’t think that is a system fault it is caused when trying to parse that specific file.

I can also work around it by doing (the folder is named by UID - your UID may be different than mine)

rm -rf /tmp/JetBrainsPerUserTemp-1000-1

then restarting userspace

systemctl soft-reboot

Again I feel the need to emphasize - this is not the place for code trouble shooting - but I will nonetheless give you a pointer.

Based on the thought that you have a code issue with the specific file

  • I located the file in question
  • I looked over the code
  • With my understanding of object oriented code
  • In line 4 you declare an import using a non-existing namespace
    import ac.mdiq.podcini.databinding.SpeedSelectDialogBinding

There is no databinding namespace inside ac.mdiq.podcini and that is likely why your editor crashes when trying to navigate to the class. The wayland message is just a red herring.

Searching for the class gives nothing.

My conclusion:
What you think is an operating system error

  • is in fact a developer oversight
  • perhaps an error
  • I don’t know
  • I didn’t write the code…

Thanks for your analysis.

Xwayland crashes not on a single file, I just give you one so that it might help to trace to the errors.

And, this is not for the purpose to find my coding errors.

It’s about the effect of changing xorg-xwayland versions.

BTW, the info regarding “no databinding namespace inside ac.mdiq.podcini” is due to the fact that databinding is automatically generated when building the project (I forgot to mention it). It’s not a coding error in my project. But I can understand it’s probably not that easy for you work through this path.

The recent changes in xwayland (or xorg, or whatever in the system) causes the system to be unstable in the aspect I described. The link @MrLavender posted is very much related to the issue I encounter.

But I don’t want to argue with you if this is a system issue. You can say that xwayland is not part of Manjaro or whatever, and I can’t argue about that.

Well - if you try to open a non existing class - a class which by your own words ‘databinding is automatically generated’ - and that action is crashing the IDE and in turn this is signaled back to the system - that is still not an operating system error but a cause and effect scenario.

As already mentioned the package as been fast tracked out of security concerns - if that change makes your IDE crash then it is an issue with the IDE - in my opinion - not the operating system.

But you are entitled to your opion that it is xorg-wayland which is crashing your IDE.

I suggest you open a bug report with JetBrains support.

Fixed by Arch in 23.2.6-1 apparently.

OK. can build that against stable too …

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.