Intel NUC no sound on TV through HDMI after reboot

I’ve got an Intel NUC11PAHi5 set up as a media player, connected to a TV w/ HDMI, running fully updated Manjaro w/ KDE, kernel 5.10, pulseaudio.

After a reboot, there’s no sound on the TV, although apps seem to work fine (ie: VLC, aplay, etc). Whatever I try software-wise (eg: kill pulse audio, suspend sink, pavucontrol, source change, …) doesn’t make any difference… the sound will only start playing after I disconnect and reconnect HDMI. I’ve examined PA sink & card info after a reboot, while a video was playing and there was no sound, and when I did a reconnect… I couldn’t find any difference in configuration (even ran outputs thru a diff), except for sink index number change after a reconnect (it’s 0 after a reboot, and 2 after a reconnect).

what am I missing?


PS: it’s not hardware… the same NUC booted to W11 works flawlessly.

I came back to this, tried a few other things (ie pipewire, upgraded the kernel to 6.10), but to no avail. I also bought a mini HDMI 2 port switch, in hopes that after a reboot I would be able to just switch it briefly to the other (unconnected) port and back, and get the sound working, but it doesn’t help… I still have to physically pull the cable out (albeit from the HDMI switch now) and reconnect it to get the sound.

So, throwing some additional hardware at a software problem didn’t work. :expressionless:


PulseAudio data shows sink-input from VLC media player is in a corked state:

1 sink input(s) available.
    index: 0
        driver: <protocol-native.c>
        flags: START_CORKED FIX_RATE 
        state: CORKED
        sink: 2 <alsa_output.pci-0000_00_1f.3.hdmi-stereo>

Archwiki suggests users disable loading of module-role-cork in /etc/pulse/ so audio applications cannot be corked by an incoming VOIP call

sudo sed -i '/load-module module-role-cork/s/^/#/' /etc/pulse/

and restart PulseAudio

systemctl --user restart pulseaudio - Starting an application interrupts other app’s sound

Hi. Thank you for your assistance, but this doesn’t make any difference… on reboot there’s no audio, like described… only a physical disconnect and reconnect of HDMI will produce audio.

PS: the config you quoted is post-reconnect - it shows sink id as 2. after reboot it’s listed as 0… you have any idea why this is the case?

I suggest delete PulseAudio user databases and cookie

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Reboot system so PulseAudio creates new database and cookie files

And post more information about PulseAudio module, profile and sink configurations for non-working state

pacmd dump

check module-role-cork is not loaded

If the card profile is not set to the working profile (HDMI stereo out + analog stereo in)

pactl set-card-profile alsa_card.pci-0000_00_1f.3 output:hdmi-stereo+input:analog-stereo

Once the profile is set to use HDMI output, check output is not muted or suspended in pacmd dump when audio is playing:

set-sink-mute alsa_output.pci-0000_00_1f.3.hdmi-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.hdmi-stereo no
1 Like