Intel HDA audio no longer detected

Since I updated my system about a week ago I have been unable to use the onboard 3.5mm headphone jacks on my machine.

I believe these are controlled by the Intel HDA Audio built into my motherboard, but I can’t find any references to it at all in Pavucontrol or Pactl on the commandline. There is no option to select the ‘Analog Stereo’ in PavuControl or if I run pacmd list-cards in the terminal. The only audio device I can currently see is the HDMI audio from my Nvidia card. (Listed as NVIDIA Corporation TU104 HD Audio Controller)

I’ve tried the commands inxi -Fa | grep Audio and lspci and it shows up as “Intel 100 Series/C230 Series Family HD Audio Vendor: Gigabyte”, so they’re definitely recognised by my system, just not by Pulse for some reason.

What’s more confusing is that cat /proc/asound/cards produces:

1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xef080000 irq 17

Also cat /proc/asound/modules produces:
1 snd_hda_intel

These seem to imply to me that Nvidia is using the snd_hda_intel driver, which doesn’t make sense? (Please correct me here if I’m wrong)

I’ve tried a couple of solutions so far, for instance writing options snd_hda_intel model=generic in my /etc/modprobe.d/alsa-base.conf, (Side note: This file didn’t exist prior to me doing this) but that didn’t appear to have any effect.
I’ve also tried:

options snd_hda_intel probe_mask=1
options snd_hda_intel dmic_detect=0
options snd_hda_intel index=1,0

as suggested on some other threads, but none of these appear to make a difference.

For what it’s worth, I dug back through my bash history and found that I’d previously executed the command pactl set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo. Tried executing it again but the command just returns the error: Failure: No such entity

I’m at a loss as to what else I can try at this point. I’ve trawled the internet for hours but I’ve yet to find a solution that works…

The output for can be found here if that helps at all…

Anything else I can try?

Thanks in advance. Let me know if there’s any additional information you want me to provide.

1 Like

Welcome to Manjaro forum @howAboutN0o

snd_hda_intel audio driver is intended to support any audio device that complies with Intel High Definition Audio (HDA) specification. (Realtek, Conexant, Sigmatel onboard audio codecs and nVidia & AMD GPU audio devices)
Most older systems (2004-2020) need only snd_hda_intel for internal devices and snd_usb_audio for external devices

alsa-info data shows 2 PCI devices detected, but no further data for the Realtek ALC1150 codec

Since the issue happened after an update, most likely suspect for this problem would be new kernel k6.8.0-1-MANJARO

I suggest you try booting system with an LTS kernel (v6.6 or v6.1) if available
Or boot from a Live USB ISO that will have older kernel and packages

Kernels v6.1 and v6.6 projected End Of Life is Dec 2026 so there is no need to rush to a later kernel if system is working
New Systems (< 2-3 years old) may need a new kernel to get hardware working optimally, but older systems are more likely to experience regressions and failures than improved performance

Thanks for the reply!

I tried downgrading from 6.8 to 6.7, then 6.6.
6.7 had no effect, but 6.6 interestingly does appear to solve it, though the only kicker is that it doesn’t appear in Pavucontrol immediately but does so about a minute later - Is there anything I can try to make this a bit faster? (If not, then I’m happy to accept this as the solution for now)

That aside, I presume there’s a regression in the latest kernel?