Intel cpu turbo turns off itself when gaming with nvidia gpu

i know similar questions were asked in forum but i have checked all those and spent my past few days looking for a solution on the Internet but found none.

The problem is that my CPU turbo boost turns itself off after few seconds when gaming, that was the problem at first and then when i tried digging more info about the cause I found that actually happens after my nVidia GPU hits 60 degrees in temperature and something sets /sys/devices/system/cpu/intel_pstate/no_turbo to 1 and won’t let me change it to 0 until the GPU is under 60 degrees (it does change it to 0 by itself after that though).
Manually it always shows operation not permitted unless it itself first change it to 0.

I’m sure it happens only because of the nVidia GPI is because i have stress tested the CPU and it always stays on full turbo no matter how long you run it even on 80+ degrees which is to be expected.

I have tried:

  • disabling TLP
  • a few different kernals too
    but nothing helped.

I also have powertop, cpupower, and thermald installed but all these are stopped and disabled and haven’t started yet after installation mostly because i use powertop, cpupower for monitoring purpose only, and as for thermald… well its just chillin there :sweat_smile:

i have tried watching the no_turbo file with lsof/fatrace to know what actually writes to that file in background but got nothing… don’t know why though

I do use intel-undervolt so kernel parameter msr.allow_writes=on is set

Edit : more info as requested, sorry its my first time posting

  Kernel: 5.13.1-3-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=f2cd0432-b018-4dd4-854b-04f03a29ba12 rw msr.allow_writes=on 
  net.ifnames=0 quiet apparmor=1 security=apparmor 
  resume=UUID=0fe754a8-82a4-44b5-b5e8-d269b1741a52 udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 81LK v: IdeaPad L340-15IRH Gaming 
  serial: <filter> Chassis: type: 10 v: IdeaPad L340-15IRH Gaming 
  serial: <filter> 
  ID-1: BAT0 charge: 24.4 Wh (56.6%) condition: 43.1/45.0 Wh (95.8%) 
  volts: 11.7 min: 11.5 model: Celxpert L18C3PF1 type: Li-poly 
  serial: <filter> status: Unknown cycles: 366 
  RAM: total: 7.65 GiB used: 1.89 GiB (24.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 8 MiB bogomips: 38408 
  Speed: 2400 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 2400 2: 2397 
  3: 2400 4: 2400 5: 2400 6: 2400 7: 2400 8: 2400 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo 
  driver: nvidia v: 470.42.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f91 class-ID: 0300 
  Device-3: Lite-On Integrated Camera type: USB driver: N/A bus-ID: 1-8:2 
  chip-ID: 04ca:7070 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting,nvidia display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.4 
  direct render: Yes 
  Local Storage: total: 931.51 GiB used: 226.59 GiB (24.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1A05 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%) 
  used: 226.59 GiB (25.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: f2cd0432-b018-4dd4-854b-04f03a29ba12 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: 6DD0-0507 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 0fe754a8-82a4-44b5-b5e8-d269b1741a52 
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 241 Uptime: 18m wakeups: 59185 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1209 
  lib: 343 flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.05 

How should I proceed?

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Don’t install both thermald and tlp, so remove thermald and set tlp to use high performance.
  4. Check your UEFI settings too and ensure they are set not to throttle performance as well.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

Sounds perfectly reasonable to me: cpu and graphics in a laptop need to be cooled properly - when the temperatures get too high the system has to take measures to not overheat.

Reducing boost options and falling back to base clock is one of those.

1 Like

Sounds like you’re not alone. So I think this is handled by hardware. Usually Lenovo gaming laptops have Lenovo vantage app (Windows only) when things like this can be configured, but no guarantee. Otherwise, there could be such a setting in the BIOS, again no guarantee. All in all, it seems by design to keep the thermals under control.

thanks for the reply :slightly_smiling_face: well but do you think 60 degrees is that high? and it didn’t used to happen in kde manjaro i used before switching to xfce even on heavy games

thanks for the reply :slightly_smiling_face: actually it starting happening a few weeks ago and i don’t know the cause, also there are no settings related to turbo in bios of this laptop… there is a performance settings but it is already set to High Performance Mode, and i don’t think vantage app had any settings related to that either, and i didn’t had this problem with my previous manjaro installation

OKAYYYY so i found a temporary solution for this and it worked:

it is by directly changing the msr values for turbo when it turns off

so i wanna ask, is it safe to change msr values every time?

“Safe” as in “no harm done”?
That is for you to decide: the higher temperatures could result in accelerated aging of all components (not just the cpu) - whether this is acceptable or not is your decision.

1 Like

yes, is it safe? i mean other than temperatures and using msr when it is not allowed by default kernal without using msr.allow_writes=on ?

yeah i get what you mean but what good is in having “turbo” in cpu if you can’t use it and i play a lot of games and as for temperatures… they are under 75 for both cpu and gpu so it should be fine.

umm… but why? i am curious, tlp faq says :

thermald: thermald’s purpose is to limit power dissipation before the laptop’s temperature gets critical. TLP enables power saving features globally to optimize battery power especially in idle and low workload situations. TLP does not conflict with thermald.

is there something else i missed?

And that’s your problem right there. I used to have both installed and got rid of thermald and my laptop is much faster now.

I have only burnt out the WiFi card after 4 years so now I keep the laptop clean (vacuum it once / month) and have created some additional warnings for T° and monitor it closely:


1 Like