Intel 8260 - Bluetooth Not Working

Hello Everyone,

I am currently running a Dell XPS 13 with an Intel 8260 wifi + bluetooth chip. I swapped the Intel card because it plays nice with Linux. I am using Manjaro KDE on the 5.8.x Kernal currently.

The Issue:
I have noticed that my bluetooth often does not work (trying to enable the bluetooth device in my settings). I found doing a reboot, etc. does not cause anything to change. However, running the following command ‘resets’ my bluetooth and I am able to enable the device and can pair things correctly:

‘nmcli networking off; sudo rmmod btusb; sleep 2; sudo modprobe btusb; nmcli networking on’

I forgot where I found this command exactly, but running the above, I can suddenly enable and start using my Intel 8260 chip with Bluetooth successfully.

Has anyone else experienced this problem and found a permanent solution? Any help / feedback / assistance would be greatly appreciated.

Thanks everyone!

So you opened up your laptop and changed the hardware WiFi card from one brand to another?

If yes: Did you update the UEFI firmware to include the 8260 driver as well?
If no: look if Dell has newer UEFI firmware for your laptop and install that (as it’s an Intel, it should be in there then)

  • If no to both: yup, those are the kinds of issues you’re running into if not replacing the existing hardware with the exact same hardware on UEFI systems (no blame on Dell, blame UEFI) and you’re lucky it’s working with your workaround…


Yes, all drivers and firmware have been updated. I’ve actually been running in this configuration since 2016 with mostly no issues on Linux, and ZERO issues under Windows 10. WIFI works perfectly under both OS’s no issues, and as I said, Bluetooth works on Linux as long as I run the above command. To also add, I previously ran Antergos (before switching to Manjaro), and the Bluetooth ran perfectly with ZERO issues there as well. So, saying all that, I do not believe this is a firmware issue or an issue with the Intel chip itself.

As I said previously, it may have been lost in the old Manjaro forums, but I found that command in my original post from someone and saved it (thankfully), and it has consistently worked to ‘enable’ my Bluetooth settings under Manjaro KDE currently.

  • I’m all out of bright ideas then. :sob:
  • For the next person coming around to help you, add the output of inxi --admin --verbosity=7 --filter --no-host please.

Anyone else? Thanks!

You have 52 views but no one is chipping in because you haven’t posted the output to the inxi yet… :man_shrugging:

Also please re-read this forum rule

I ran the command before executing my workaround. So, this is the output with the Bluetooth adapter in a ‘broken’ state.

Output of inxi --admin --verbosity=7 --filter --no-host is:

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=f6a1d0ce-d328-4151-87d1-2500901e49e9 rw apparmor=1 
           security=apparmor resume=UUID=fc440987-1c94-45a3-9c45-fcc91942087e udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9350 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 076F9T v: A00 serial: <filter> UEFI: Dell v: 1.13.0 date: 02/10/2020 
Battery:   ID-1: BAT0 charge: 35.7 Wh condition: 37.5/57.5 Wh (65%) volts: 8.0/7.6 model: SMP DELL JHXPY53 type: Li-poly 
           serial: <filter> status: Discharging 
Memory:    RAM: total: 7.64 GiB used: 1.78 GiB (23.2%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake family: 6 model-id: 4E (78) 
           stepping: 3 microcode: D6 L2 cache: 3072 KiB bogomips: 19204 
           Speed: 2701 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2701 2: 2797 3: 2699 4: 2744 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
           smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:1916 
           Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo bus ID: 1-5:3 chip ID: 0c45:670c 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3200x1800 s-dpi: 96 s-size: 846x476mm (33.3x18.7") s-diag: 971mm (38.2") 
           Monitor-1: eDP1 res: 3200x1800 hz: 60 dpi: 280 size: 290x170mm (11.4x6.7") diag: 336mm (13.2") 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 bus ID: 3a:00.0 chip ID: 8086:24f3 
           IF: wlp58s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 86.96 GiB (36.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM951 NVMe 256GB size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: BXV77D0Q scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 43.95 GiB size: 43.00 GiB (97.86%) used: 25.80 GiB (60.0%) fs: ext4 dev: /dev/nvme0n1p5 
           label: N/A uuid: f6a1d0ce-d328-4151-87d1-2500901e49e9 
           ID-2: /boot/efi raw size: 100.0 MiB size: 96.0 MiB (96.00%) used: 46.2 MiB (48.1%) fs: vfat dev: /dev/nvme0n1p2 
           label: N/A uuid: 38B4-DDC3 
           ID-3: /home raw size: 85.36 GiB size: 83.52 GiB (97.84%) used: 12.10 GiB (14.5%) fs: ext4 dev: /dev/nvme0n1p7 
           label: N/A uuid: 26de23b6-af2b-4302-ac31-f6eb9caea968 
           ID-4: /run/media/aahmad/DRIVE raw size: 104.66 GiB size: 104.66 GiB (100.00%) used: 49.01 GiB (46.8%) fs: ntfs 
           dev: /dev/nvme0n1p4 label: DRIVE uuid: 022401A424019C33 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p6 label: N/A 
           uuid: fc440987-1c94-45a3-9c45-fcc91942087e 
Unmounted: ID-1: /dev/nvme0n1p1 size: 499.0 MiB fs: ntfs label: N/A uuid: 4CB29579B295686A 
           ID-2: /dev/nvme0n1p3 size: 16.0 MiB fs: <superuser/root required> label: N/A uuid: N/A 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-3:2 info: Intel Bluetooth wireless interface type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 
           speed: 12 Mb/s chip ID: 8087:0a2b 
           Device-2: 1-5:3 info: Microdia Integrated Webcam HD type: Video driver: uvcvideo interfaces: 2 rev: 2.0 
           speed: 480 Mb/s chip ID: 0c45:670c 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 38.0 C sodimm: 41.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 243 Uptime: 4m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1427 lib: 399 flatpak: 0 
           Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

TTT, thanks guys!

Hey Guys,

Mini-update, found a few posts that sound like my issue:

Any thoughts on what to do here? TIA.