Installing wordlists using pamac results in an error

Hi everyone,

Recently I was trying to install the wordlists (similar to the ones present in Kali and BlackArch operating systems). However, in my case, I got an error while installing the wordlists package from the AUR using pamac.

The command I ran to install the wordlists package
sudo pamac install wordlists


==> Validating source files with sha256sums...
    dirbuster-kali-1.0-1kali4.tar.gz ... FAILED
    dirb-debian-2.22-0kali3.tar.gz ... FAILED
    v3.1.0.tar.gz ... Passed
    2022.4.tar.gz ... Passed
==> ERROR: One or more files did not pass the validity check!
Finished with result: exit-code
Main processes terminated with: code=exited/status=1
Service runtime: 3min 53.500s
CPU time consumed: 27.882s
Error: Failed to build wordlists

To me, it seems like these two packages failed the sha256 validate checks, I’ve checked their sha256checksums in the PKGBUILD file from here

To build (1):
  wordlists  0.3-1    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] 

I am not sure what’s the issue here, can anyone please check this out and suggest me some ways ?

I just tested and the checksums are correct. Remove your existing build directory; i.e., /var/tmp/pamac-build-himan10/wordlists/, and try again.

Thanks for replying.

I don’t have any directory called wordlists under the pamac-build-hi-man.
However, I do have wordlists dir. present somewhere else, it’s in another git repo on my system which I downloaded back in 2020, so does that create any difference?

Also, how did you test the checksums, can you please guide me? Did you first download the tar.gz package and then checked the checksums of the file present inside it ? I wanted to do the same but I wasn’t sure how to.

I ran pamac build wordlists and the checksums all passed.

:information_source: Tip: Don’t use sudo with pamac, it will prompt for authentication when required.

You can also build the package manually. See Arch User Repository - ArchWiki

sudo pacman -Syu --needed base-devel git
git clone
cd wordlists
updpkgsums && makepkg -srcif
1 Like

Well, really really thanks to you for the suggestions, it worked perfectly, and now I have got the package wordlists installed in my system.

First of all, the pamac build wordlists command resulted in the same error where the first two packages as also shown in the original post, failed in the sha256 checksum certification test.

Then, I manually installed the package by having its PKGBUILD, and here also I ran into an error, which is shown in the given image:

“There was no such file or directory” because it was trying to cd into the directory whose name is similar to its compressed archive package file, however at the time of uncompressing these archive packages, they got names like this → dirbuster-9edc0490c05f669a9bfc9d63772fd2a8aaa18daa and dirb-2db13759f587816784a149dd3c20dbaded6e0957, so later when it was showing those errors, I just mv the directories name to the ones the command was expecting, and finally it got installed.

Thanks a lot, today I learnt how to install the AUR package manually, and being responsible for upgrading them every time in the future as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.