Installing video-nvidia causes KDE/sddm to fail to load

I have Intel integrated graphics and an EVGA FTW3 RTX-3080. Can boot to KDE when no nvidia drivers are installed and prioritising IGD graphics in BIOS, but once nvidia drivers are installed and switched to PCIe graphics, sddm gives errors first of being “cannot read display number from pipe” and KDE can not start. Result is cannot boot to DE.

Could I please have some help troubleshooting so I can get the driver working without breaking my DE?

Running systemctl start sddm has no output as it is active from boot. status shows this:

May 10 00:15:28 pc sddm[873]: Failed to read display number from pipe
May 10 00:15:28 pc sddm[873]: Display server stopping...
May 10 00:15:28 pc sddm[873]: Attempt 2 starting the Display server on vt 1 failed
May 10 00:15:29 pc sddm[873]: Display server starting...
May 10 00:15:29 pc sddm[873]: Adding cookie to "/var/run/sddm/{c8bd3692-c509-4d65-aec5-a0d80c4f41dd}"
May 10 00:15:29 pc sddm[873]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt1 -auth /var/run/sddm/{c8bd3692-c509-4d65-aec5-a0d80c4f4>
May 10 00:15:30 pc sddm[873]: Failed to read display number from pipe
May 10 00:15:30 pc sddm[873]: Display server stopping...
May 10 00:15:30 pc sddm[873]: Attempt 3 starting the Display server on vt 1 failed
May 10 00:15:30 pc sddm[873]: Could not start Display server on vt 1

startplasma-wayland fails with errors such as:

No backend specified through command line argument, trying auto resolution
The Wayland connection broke. Did the Wayland compositor die?
kdeinit5: communication error with launcher. Exiting!
Error: could not determine $DISPLAY.
"kdeinit5_shutdown" () exited with code 255

I’ve tried to include journalctl -b but it was too long. Let me know if more info is needed.

provide also:
inxi -Fazy
mhwd -l && mhwd -li
dont use wayland + nvidia + kde, its a mess…

1 Like

Hi, just below.
inxi -Fazy

  Kernel: 5.17.1-1-rt16-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-rt-x86_64
    root=UUID=2195fc09-b34f-4210-a024-71688561d6fa rw
    root=/dev/mapper/luks-6809a4fb-d0de-4307-9db4-3552700019fb apparmor=1
    security=apparmor udev.log_priority=3 nvidia-drm.modeset=1
  Console: pty pts/0 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MAG Z690 TOMAHAWK WIFI (MS-7D32)
    v: 3.0 serial: <superuser required> UEFI: American Megatrends LLC. v: H.20
    date: 03/02/2022
  Info: model: 12th Gen Intel Core i7-12700K bits: 64 type: MST AMCP
    arch: Alder Lake family: 6 model-id: 0x97 (151) stepping: 2 microcode: 0x1A
  Topology: cpus: 1x cores: 12 mt: 8 tpc: 2 st: 4 threads: 20 smt: enabled
    cache: L1: 1024 KiB desc: d-4x32 KiB, 8x48 KiB; i-8x32 KiB, 4x64 KiB
    L2: 12 MiB desc: 8x1.2 MiB, 1x2 MiB L3: 25 MiB desc: 1x25 MiB
  Speed (MHz): avg: 734 high: 801 min/max: 800/5040:5120:5300:4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 700 2: 700 3: 701 4: 701
    5: 700 6: 701 7: 700 8: 701 9: 700 10: 701 11: 701 12: 701 13: 738 14: 750
    15: 801 16: 801 17: 801 18: 800 19: 800 20: 801 bogomips: 144383
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel AlderLake-S GT1 vendor: Micro-Star MSI driver: i915
    v: kernel ports: active: none
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0
    chip-ID: 8086:4680 class-ID: 0380
  Device-2: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor:
    driver: N/A alternate: nouveau pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:2216 class-ID: 0300
  Display: server: v: with: Xwayland v: 22.1.1 driver: X:
    loaded: N/A failed: nvidia gpu: i915 note:  X driver n/a tty: 80x25
  Message: GL data unavailable in console. Try -G --display
  Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: NVIDIA GA102 High Definition Audio vendor:
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-3: Micro Star USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:3 chip-ID: 0db0:b202
    class-ID: 0300
  Sound Server-1: ALSA v: k5.17.1-1-rt16-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.49 running: no
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: Micro-Star MSI driver: igc
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 05:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:10 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 931.52 GiB used: 38.42 GiB (4.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P5PSSD8
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P7CR402 temp: 29.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 043 scheme: GPT
  ID-1: / raw-size: 209.96 GiB size: 205.6 GiB (97.93%)
    used: 38.39 GiB (18.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6809a4fb-d0de-4307-9db4-3552700019fb
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 34.1 MiB (35.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 447 Uptime: 4m wakeups: 2 Memory: 31.15 GiB used: 736 MiB (2.3%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
  Packages: 1309 pacman: 1282 lib: 343 flatpak: 17 snap: 10 Shell: Zsh
  v: 5.8.1 running-in: pty pts/0 (SSH) inxi: 3.3.15

and drivers:

> 0000:01:00.0 (0300:10de:2216) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0380:8086:4680) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

Wayland needs KMS enabled . Intel enables it be default, but on NVIDIA it needs to be enabled explicitly at the kernel parameter: nvdia-drm.modeset=1

But with nvidia it would be better to go with x11: startplasma-x11

I understand X11 is less prone to issues like this but if I can get Wayland working, that would preferable.

Already set nvdia-drm.modeset=1. I built using nvidia-dkms instead and now can get to the login screen. Logging in selecting wayland in the GUI sometimes takes to black screen, but i can always run startplasma-wayland to load up the DE. Logging in selecting X11 from GUI obviously works every time…

What logs should I be looking at on the occasion that Plasma crashes right after logging in?

Well the thing is:

So first you need to be sure that the driver is loaded properly. Check dmesg :wink: Add the nvidia driver also to init images (mkinitcpio)

It’s loading now :sweat_smile: X11 works as it should, Wayland can be started using startplasma-wayland or plasmashell once logged in and greeted with the blank screen and cursor. I think I may just stop trying to get Wayland to work, it’s taken up enough time as it is! At least I know have a working DE.

For anyone’s future reference, try to follow the relevant steps on the NVIDIA guide on Arch Wiki and install the DKMS package, instead of video-nvidia. This was an issue on kernel 5.15 and 5.17 in which building from dkms solved for me.