Installing video-nvidia-450xx… error: target not found: linux56-nvidia-450xx


I have a fresh install of Manjaro and tried to install the legacy Nvidia driver instead of the default nouveau driver but pacman fails:

Installing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases…
error: target not found: linux56-nvidia-450xx
core is up to date
extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!

The problem seems to be that the package databases… has no entry for linux56-nvidia-450xx

How can I fix that?
My system has an AMD Ryzen 5 3600 6-core processor with an Nvidia Geforce GT 1030 graphics card.

Thanks in advance for any help.


The 5.6 series kernel has reached end of life. Please upgrade/downgrade to a still supported version (e.g. 5.4 - which is the long-term support version, or 5.8).


Hi pobrn,

I upgraded to linux-latest 5.8.1 and also installed the Linux-latest-nvidia 440x 5.8.1 driver but after rebooting my machine is still using the nouveau driver and trying to apply the nvidia 440x driver it is complaining
warning: nvidia-440xx-utils-440.100-1 is up to date – skipping
error: target not found: linux56-nvidia-440xx
warning: linux58-nvidia-440xx-440.100-12 is up to date – skipping

Upgrading the kernel isn’t enough it seems, what should I do to get the driver working?

Regards, Ulrich

Is nouveau blacklisted?

Hi pobrn,

No nouveau isn’t balcklisted but it has a very sluggish performance on a dual monitor setup, almost unusable to the point that I choose to use only one monitor with the nouveau driver.

But the problem is solved, I had installed Manjaro from a live system that I downloaded earlier this year containg the 5.6 kernel and since upgrading the kernel to 5.8 didn’t help I downloaded the latest Manjaro and chose to start the live system with legacy drivers up front, that did the trick!

So thank you for suggesting a different kernel which led me to a solution.

Kind regards, Ulrich

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.