Installing ungoogled-chromium binary on Manjaro

I’ve noticed that there is a [binary version of ungoogled-chromium specifically for Arch Linux on the ungoogled-chromium website

ungoogled-software (dot) github (dot) io/ungoogled-chromium-binaries
(My account after the forum migration can’t post links yet, sorry for the weird URL)

I was surprised to see this package doesn’t seem to exist in Manjaro repos or in the AUR (just the non-binary version is available, and takes over an hour to compile).

Am I missing something? If not, what is the best way to install this package?

Would love to see this in official repos if the Manjaro team were open to that @philm

Yes the binaries were all removed from AUR. You have to build it yourself or add a 3rd party repo.

I host it if you want (specifically built on/for manjaro-stable):
(ignore the ublock package … I was testing something)
https://cscs.gitlab.io/aur-compiled/

5 Likes

Whoa, sounds like there’s a story there. Did something happen?

My understanding is AUR doesnt exactly like binary packages when source is available…

…Specifically: An AUR package…

…should not contain the binary tarball created by makepkg, nor should it contain the filelist.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Submitting_packages
https://wiki.archlinux.org/index.php/AUR_submission_guidelines

1 Like

Huh… that doesn’t make sense to me. There are tons of large packages (Brave?) that have both binary and open source packages. For end-users, the open source packages take a huge amount of time and processing power to compile… That really sucks.

Brave provides a binary.
ungoogled is technically a patchset and thus releases no binary other than those submitted by unrelated third parties … such as in the case of arch, those created by available PKGBUILDS … so its a bit different situation.
(or at least thats how I understand it … :sweat_smile:)

1 Like

Is it still not possible to have Chromium and Ungoogled-Chromium installed side by side?

1 Like

It is not.

1 Like

@cscs, if you are maintaining ungoogled-chromium in your repo, how about uploading it to the community repos?

4 Likes

I tried to build from AUR and it took 4 hours and i was in the middle and seen complains it may take a day and end in error so i terminated.

This is how i have installed ungoogled-chromium today from un-official repo on Arch/Manjaro. Just 2 commands:

  1. sudo su
  2. pacman-key --keyserver hkps://keys.openpgp.org -r 3DEA62513C8035383A245A12E5786B42E8E5D565;pacman-key --lsign-key 3DEA62513C8035383A245A12E5786B42E8E5D565;echo -e "[jk-aur]\nServer = https://repo.vin.ovh/arch/\$arch" >> /etc/pacman.conf;pacman -Sy ungoogled-chromium pepper-flash;sed -i "/jk-aur/d" /etc/pacman.conf;sed -i "/repo.vin.ovh/d" /etc/pacman.conf;pacman -Sy;exit.
1 Like

Solo he sacado una cuenta para decir gracias. Eres un crack
I just took out an account to say thank you. You are awoseme