Installing release from github for testing broke existing stable install

I got in a bit over my head earlier today. I’m not used to building from source and usually just stick with what’s in the package manager, or, occasionally, the AUR.

I’m running a system with Manjaro KDE edition. System was fully up to date and working before I started this adventure.

I had PrusaSlicer installed through the package manager (prusa-slicer 2.3.0-1) and everything worked fine. I discovered that there was a feature I wanted to try out that was implemented in the source, but not the released version. I went to the linux readme on github and followed the instructions there. My list of commands ran something like this:

git clone /home/snakerbot/PrusaSlicer-git
cd PrusaSlicer-git
mkdir build
cd build
make -j1
sudo make install

Not only did this new install not work, (I get a splash screen, then a window with the message “An assertion failed! ./include/ws/dynarray.h(837): “uiIndex < m_nCount” failed in Item().” if it matters. Clicking the “continue” button on this prompt just closes the window and nothing else happens.) but it managed to break my existing install of 2.3.0-1 while it was at it (same error). Reinstalling through the package manager didn’t fix it.

So I have two questions:

  1. How do I fix my stable release of PrusaSlicer?
  2. How do I build from source in such a way that it is kept isolated from any existing stable installs?

Installing prusa-slicer-git from the AUR would be the best way.

Install it to /opt/ or /usr/local/ if you must.

Turns out it was already doing that. The application was installed to /usr/local/. Still not sure why it broke the existing install or why reinstalling from the package manager didn’t fix it. This probably isn’t the correct way, but I deleted all the build files and the application file, then reinstalled the stable from the package manager, and that brought it back.

I saw this at first, but didn’t actually know what the -git packages did, and got confused by the differing version numbers. I thought the -git package was a lower version. Anyway, that led me to discovering that the error message I was getting from my git install of PrusaSlicer is a bug there, not anything to do with Manjaro.

Thanks for the help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.