Installing rdiff-backup

I’m having trouble installing rdiff-backup. Install hangs at this point:

diff --git /home/dad/.cache/yay/rdiff-backup/.nvchecker.toml /home/dad/.cache/yay/rdiff-backup/.nvchecker.toml
new file mode 100644
index 0000000..204ed7f
--- /dev/null
+++ /home/dad/.cache/yay/rdiff-backup/.nvchecker.toml
@@ -0,0 +1,3 @@
+source = "pypi"
+pypi = "rdiff-backup"
diff --git /home/dad/.cache/yay/rdiff-backup/PKGBUILD /home/dad/.cache/yay/rdiff-backup/PKGBUILD

Any help appreciated

How are you installing it? It works here.

I’ve used sudo yay rdiff-backup and yay -S rdiff-backup. I’m a newbie manjaro user so extremely unfamiliar with the package/install tools. During the install I keep choosing a, for A[All], as the option as I do not know what the other options do. Keeps getting stuck on the line:
diff --git /home/dad/.cache/yay/rdiff-backup/PKGBUILD /home/dad/.cache/yay/rdiff-backup/PKGBUILD
new file mode 100644
index 0000000…3180f69

Try building it using Manjaro’s package manager, Pamac, either via the GUI or by entering the following command in a terminal:

Note: do NOT use sudo for this command: pamac build rdiff-backup

You may have to enable AUR support in Pamac (via the GUI: Preferences => Third Party), and you may also have to install the base-devel package which provides a lot of the tools required to build packages from the AUR.

I just ran the pamac build command & it took a total of 34 seconds (including the delay it took for me to enter my password when prompted) to build & install rdiff-backup:

adding 'rdiff_backup-2.2.6.dist-info/entry_points.txt'
adding 'rdiff_backup-2.2.6.dist-info/top_level.txt'
adding 'rdiff_backup-2.2.6.dist-info/RECORD'
removing build/bdist.linux-x86_64/wheel
Successfully built rdiff_backup-2.2.6-cp311-cp311-linux_x86_64.whl
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "rdiff-backup"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: rdiff-backup 2.2.6-2 (Sat 03 Feb 2024 07:51:40)
==> Cleaning up...

Checking keyring...                                                                                                                        [1/1]
Checking integrity...                                                                                                                      [1/1]
Loading packages files...                                                                                                                  [1/1]
Checking file conflicts...                                                                                                                 [1/1]
Checking available disk space...                                                                                                           [1/1]
Installing rdiff-backup (2.2.6-2)...                                                                                                       [1/1]
Transaction successfully finished.

Wow - that did it. Thank you very much. I did not have to enable AUR support - I must have done that when I installed/enabled yay.

1 Like

I’m getting the message:
WARNING: this command line interface is deprecated and will disappear, start using the new one as described with ‘–new --help’.

Apparently the installed version 2.2.6 is an alfa version. The version I have on my ubuntu machine is 2.0.5. Two questions please, how to uninstall and how to install a stable version?

This is a rolling release distribution and you can’t go back.

You should adapt to the new cli options, sooner or later they will change on your ubuntu system as well. And judging from their Github page: Release Final minor release v2.2.6 · rdiff-backup/rdiff-backup · GitHub it’s not alpha but an actual stable release.

It is (was) a warning.
No need to panic.

Wrong assumption!

It essentially says:
it’ll work - but may not work the same way in the future

… different interface …

Just use it for now.

and find out what the warning meant or just use the new interface - find out how with:
new --help
as the warning message suggested

Start the thing with that “–help” command line switch - and you’ll see the help message.

how (or: why?) is the problem marked as solved
when there is still an issue?

The issue was about installing which was solved.

… ahh - I missed the literal

interpretation :wink:

Its still a bit unclear … but maybe you were missing base-devel.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.