Installing qt-installer-framework on raspberry pi 4

I had been working on a qt project which I have to deploy. I found cqtdeploy a good choice for deploying qt projects but the package is only available for x86 architectures. So I went to compile it my own but it required qt-installer-frame work for making which was another package not available for arm64 architecture. Then I tried to install qt-installer-framework from source and ended up in failure.

here are the step that I’ve followed.

git clone
cd installer-framework
mkdir build
cd build
qmake ../*.pro (using qt  installed from default repository)
make -j4
sudo make install

Although the source compiled and installed successfully, building the cqtdeploy after all of this thrown the same error saying QtInstallerFramework is not found. I think the installation didn’t took place in right folders that qmake could detect it. I am not much experienced in compiling packages. Am I doing anything wrong?

You can try the qt-installer-framework package in the AUR. Just add aarch64 to the arch=() line in the PKGBUILD before building it.