Installing nvm from official repos and using zsh with oh-my-zsh

I downloaded nvm from the offical repos.

I am using zsh with oh-my-zsh.

After installing nvm, the console didn’t find nvm, then I read about it and found out that the source/usr/share/nvm/ needs to be before oh-my-zsh is added.

I moved it and it worked until restart.

After that i tried to see why it can’t find nvm.

Writing which nvm printed out file contents for me and doing the same in sudo resulted in the output u can see below.

sudo which nvm
which: no nvm in (/home/taff/.nvm/versions/node/v12.18.4/bin:/home/taff/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/va

Ive tried to search for similar issues, but haven’t found anything.


this is what my .zshrc conf looks like


Reinstalled nvm and got it working. Restarts don’t affect it now, but the which problem still persists at the moment.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.