Installing nvidia driver broke GUI

GUI broke when installing nvidia closed sources driver

I’ve been having problems with my system, in the part of Graphical Interface freezing sometimes, so I thought it might have been a problem with the drivers as I saw some people when updating it fix their problem.

So I installed the nvidia driver from the application for managing devices in manjaro, after reboot, the computer is not able to get to a GUI, I’m forced to log via TTY, I tried to start with startx with no success showing an error, this is the log (/var/log/Xorg.0.log):



The resolution of the screen is not normal at all, I tried to resize it, but it seems that the system doesn’t recognize the screens

When I try to run xdpyinfo displays: xdpyinfo: unable to open display “”.

I’m able to have an operating system at least, that I can interact with, what can I do to fix it?

For trying to give more information this is the xinitrc:

I use Manjaro KDE, what other information can I give for any further assistance? Thank you for helping

You must install linux61-nvidia

Could you give me the command to install it?

Also that doesn’t depend for different graphics card?

I search the driver in and it showed a website:

software .manjaro .org/package/linux61-nvidia

Is this command legit?

pamac install linux61-nvidia 

Yes, though why you didnt get the correct packages for your kernel by mhwd
( sudo mhwd -f -i pci video-nvidia )
is still a mystery.


It seems that the package linux x61 was already installed, so I started to search more deeply in nvidia drivers, and started to follow a guide to search for the specific driver that I needed for my graphics card.

One of the steps was to do a pacman -Syu to upgrade the system and reboot to make the updates appear, and magically the problem was solved :+1:t3:

I used the GUI of manjaro software management, I didn’t manually install it, on the contrary I didn’t want to do it manually as I could have broke my system

Manjaro Settings Manager is just a gui for mhwd.
I dont care if you passed the command or clicked a box.

Somehow you were in a partial-upgrade state.
Glad its fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.