Installing new hard drive

Hello guys in my laptop I installed an old HDD where there was Windows 10 installed with C(system) and D(some necessary files) now I have two separate drives SSD with manjaro and HDD with windows 10. So need to remove Windows 10© but keep files(D).

Look at how the system sees the attached storage… :arrow_down:

lsblk
fdisk -l

Once you’ve identified what was the Windows system drive, you can reformat it with a filesystem of your choice, and then after updating GRUB, Windows should be gone from the boot menu as well if it was in there in the first place. :wink:

I deleted C disk(80gb) from kde partition manager created new ext4 but now I can’t delete unnecessary files from my old HDD
How can I create one drive from this HDD two partitions ?

The simplest way would be to copy the files to your $HOME on the SSD, wipe the entire partition table of the HDD ─ make sure you have the correct drive! ─ and then create a single partition on it, spanning the whole drive. Then, add a record for that partition to your /etc/fstab with a mountpoint of your choosing ─ best would be a directory inside your $HOME ─ and then mount that partition to said directory and move the files into it.

The fact that you’ll have the new partition defined in /etc/fstab and that it’ll be mounted under your $HOME then also guarantees that you’ll have easy access to those files again, with the proper permissions.

1 Like

Thanks a lot I’ve created one partition, mounted to home/username/HDD directory, added to etc/fstab with this settings UUID=cb9a2add-8849-4008-8171-4c42b9f4c654 /home/username/HDD ext4 defaults,noatime 0 0 but still can’t create folders or move files there

You have to make sure that the directory is owned by you and not by root, and that the permissions are correct. :wink:

sudo chown your_username:your_username /home/your_username/HDD
sudo chmod 755 /home/your_username/HDD

You can also use a 700 permission mask instead of 755, if you like. It’s in your home directory, so they’re your files, and if you don’t want to make them visible to other users, then 700 is good. :wink:

I messed up something after restarting I end up in emergency mode timed out waiting for device, dependancy failed for /home/username/HDD dependancy failed for Local File System I removed(rmdir) /home/username/HDD and tried umount dev/sda1 but it’s no use

Recreate the directory ─ as yourself, not as the root user ─ and modify the entry for the drive in /etc/fstab so that the mount options are defaults,nofail,noatime ─ no spaces between the options. If you don’t want the device auto-mounted at boot, add the noauto option as well.

Your problem is probably caused by the system wanting to mount the device too early in the boot process.

1 Like

solved that problem appreciate your help but HDD still doesn’t mount automatically and still can’t modify it sorry to bother you some much :confused: :confused: :worried:

1 Like

Are you sure that the UUID is correct? :thinking:

I finally did it thank you very very much

1 Like

So, what was the secret sauce? :smiley:

I forgot to change owner after recreating the directory :grin::grin:

I told you so. :wink:

Yeap you were right thanks again

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.