Installing MATLAB on a fresh install of Manjaro KDE

New to the forum here, in fact I’m new to the Linux world. It’s been a week since I installed Manjaro KDE and I have almost installed all the stuff that I use on Windows. The only thing I’m having problems with is installing Matlab. I looked at the system requirements of Matlab and there it’s stated that only Ubuntu is supported. Does it mean I can’t install Matlab on Manjaro? I’m very new to Linux and don’t know much about the command line. Is there an easy way to install Matlab in Linux like in Windows?

Welcome to the forum! :wink:

I hope you’ve installed the software via the repository and/or via Snap or FlatPak, and not from the vendors’ websites. :slight_smile:

matlab is available from the AUR (Arch User Repository). Here’s the fastest way to install it. Open up a terminal window and issue the following commands verbatim… :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu yay
yay -Sya matlab

The first command will sync your mirrors and run a full system upgrade ─ there was a major upgrade only two days ago, and it is important that you keep your system up-to-date, because Manjaro is a (curated) rolling-release distribution. Best is to subscribe to notifications for the #announcements category, so you will remain apprised of major updates.

The command will also pull in yay, which is an AUR helper program. The second command invokes yay for downloading and installing matlab. It’s proprietary software, so it’s most likely a binary package that doesn’t require any compiling.

Once the two commands have finished running, you’ll need to reboot your system because the update encompasses a newer kernel, but matlab should normally be readily available from the menu right away. :wink:

Not so fast. :wink: There’s some manual intervention involved, see the PKGBUILD.

Also, it’s been flagged out of date since March.

1 Like

I hope you’ve installed the software via the repository and/or via Snap or FlatPak, and not from the vendors’ websites.

Yess I have downloaded everything from the “Add/Remove Software” application. That’s the only way I know to install software haha.

I did as you said but it’s showing I have to “build” the application(?)
I’m not being able to upload the screenshot here sorry.
My knowlegdge on Linux commands is practically 0. I searched up the installation process for matlab on linux in the Matlab forums and they said I just have to download the matlab linux zip from their official site(which I did) and click on the “install.sh” which I did, but still nothing happens. Will shifting to Kubuntu make the process simpler?

You have to make sure that it has execute permission. And you’ll probably need to execute that as root for a system-wide install. I doubt whether it’ll have a builtin way of elevating permissions via polkit.

I think it has execute permission, because when I click on it, I’m getting one window with open, execute and cancel. When I click on “execute” nothing happens. I was trying to follow the tutorial from the arch linux wiki. (I’m confused as to why I can’t include a link in my replies :slightly_frowning_face:)

I did manage to run the install script. But it shows this error-

terminate called after throwing an instance of ‘std::runtime_error’
what(): Unable to launch the MATLABWindow application
Aborted

2 Likes

Have you solved the problems? I met the same error. And both Arch Linux KDE and Manjaro KDE can’t install matlab properly. It seems that matlab don’t support Arch-based system. I check the error and Arch-WiKi. The error is mainly about the version of libpango or libglib. But I don’t know how to solve it.

There’s also Octave if you want a FOSS Matlab clone.

1 Like