Installing manjaro with MBR and legacy booting

Hi, New to Manjaro, moving from Ubuntu. I installed it but can’t boot. DISTRIB_RELEASE=22.0.4. Was expecting a dual booting. Partitions are from gparted:

Disk /dev/sda: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZ7LN512
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 210635742 210633695 100.4G 7 HPFS/NTFS/exFAT
/dev/sda2 210636800 211888127 1251328 611M 27 Hidden NTFS WinRE
/dev/sda3 211892222 1000215144 788322923 375.9G 5 Extended
/dev/sda5 329078784 348608511 19529728 9.3G 82 Linux swap / Solaris
/dev/sda6 348610560 543920127 195309568 93.1G 83 Linux
/dev/sda7 543922176 1000215144 456292969 217.6G 83 Linux
/dev/sda8 * 211892224 329075817 117183594 55.9G 83 Linux

Bios options:
secure boot off
legacy first.

The manjaro partition is marked boot as it should be. I tried to update the grub after .iso booting but to no avail. When I enter the bios and select my SSD disk, nothing happens just redisplay of BIOS startup options. Is the MBR broken although the partition table seems OK.

I had a look in the forum but didn’t see anything to fix this.

Help appreciated. Thanks.

Hello @mauricebis and welcome :wink:


sudo parted -l

Dump question: How did you do that?

Thanks for your reply. Sure:
sudo parted -l
lists the manjaro partition as bootable. As to regenerating the grub, I used the procedure:

    sudo manjaro-chroot -a 
    grub-install /dev/sda 
    grub-install --recheck /dev/sda
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
ERROR: mkdir /var/lock/dmraid
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
Found Windows 10 on /dev/sda1
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi

PS. By the way, I’m a bit puzzled at the notifications fields in the user profile of the forum. I’d just like to receive an email when reply is posted. How do I do that?

Maybe this is better:

grub-install --verbose --force --target=i386-pc --recheck --boot-directory=/boot /dev/sda

Added verbose so that you can see what’s going wrong. I have a feeling that it skips writing the MBR, because there is a problem of some sort. --force will write it regardless.

Thanks. I tried that but failed. Now, in the output of grub-install, apparently it doesn’t detect the manjaro partition which is flagged bootable. Also, the output of the MBR by dd lists a string “GRUB GeomHard DiskRead Error” which seems to indicate that the MBR is not right. Finally, is it necessary to recreate the grub.cfg file after grub install?

If that is what the log says, then you can assume that. I have no idea, since I am not in front of your computer and don’t have the full log. :man_shrugging:

Not every time, but that ensures that the grub.cfg is written.

in mbr mode , calamares cant install with extented partitions :
no more than 4 primary partitions
so it fails on both case mbr ( using extend partition ) and efi ( not gpt partition )

1 Like

I’m sorry this is not correct, an extended partition is a must on most mbr installs. I’m writing this from this drive:

Partition Table: msdos
Disk Flags: 
Number  Start   End    Size    Type      File system     Flags
 3      106MB   128GB  128GB   extended
 6      107MB   124GB  124GB   logical   ext4
 5      124GB   128GB  3669MB  logical   linux-swap(v1)  swap

When trying to install from the ISO: In case your firmware allows both UEFI and BIOS installs, have you booted the non-UEFI entry via firmware?

The boot flag doesnot matter for booting Manjaro.

Before installing Manjaro had you switched off FastBoot in Windoof? Otherwise Windoof has not been shut-down properly, possibly.

Installation to logical partitions inside an extended partition should be possible. At least, it was in the past.

Please, post output of

inxi -Fza

I noticed that fdisk warned that the partitions were not in the right order. I fixed that with the option x and f and thought this was the culprit but no. As there was a string of chars in the MBR saying grub bad disk geometry, I tried to regenerate the MBR. I found a debian program install-mbr and executed it to fix this. That chain of chars disappeared. Good. but not enough. I tried to see if in Ubuntu the problem would be the same and it is. I can’t boot the machine. I must stay I’m a bit at my wits’ end with this. Of course, I could try GPT and UEFI but I fear to loose my windows 10 since I haven’t got any installation copy of the system and programs so I’d rather not do that.

Here is the output of inxi

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=fr_FR keytable=fr tz=UTC
    misobasedir=manjaro misolabel=MANJARO_XFCE_2204 quiet
    systemd.show_status=1 splash apparmor=1 security=apparmor driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 2479AV7 v: ThinkPad L530
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 2479AV7 serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: G3ET97WW(2.57) date: 11/14/2013
  ID-1: BAT0 charge: 4.7 Wh (100.0%) condition: 4.7/56.2 Wh (8.3%) volts: 12.4
    min: 10.8 model: SANYO 45N1001 type: Li-ion serial: <filter> status: full
  Info: model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1879 high: 3300 min/max: 1200/3300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1200 2: 3300 3: 1817
    4: 1200 bogomips: 20761
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3,
    VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: Seiko Epson 0x3152 built: 2010 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Centrino Wireless-N 2200 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:0891
    class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 1000 bus-ID: 0c:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp12s0 state: down mac: <filter>
  Local Storage: total: 484.4 GiB used: 9.12 GiB (1.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7LN512HCHP-000L1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 5L0Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB DISK 2.0 size: 7.46 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
    rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 206 Uptime: 12m wakeups: 2 Memory: 7.35 GiB
  used: 2.24 GiB (30.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1144 libs: 317 tools: pamac pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25


From my perspective, I would encourage you to use UEFI and GPT on your system. I don’t see what benefit you get when using modern OS’s. OK, you can install older OS’s with legacy support or use secure boot for Windows, while Linux be installed in legacy. But GPT is a good replacement for the outdated MS-DOS and is more stable and nowadays better supported.

But yeah, I get that, you need to back up everything and reinstall everything on GPT. It is your choice.

Yes, reinstalling windows 10 with the licensed software would be difficult, because I haven’t got any installation disk.

So, as much as possible, I’d like to keep with things as they were before I tried manjaro. It all worked fine.

I reverted the Bios to default settings in case I might have changed things there. But Nope, this doesn’t solve the pb.

The grub installation goes fine without errors. Extracted from the log:

grub-mkimage --directory '/usr/lib/grub/i386-pc' --prefix '(
,msdos8)/mnt/boot/grub' --output '/mnt/boot/grub/i386-pc/core.img'  --dtb '' --s
bat '' --format 'i386-pc' --compression 'auto'   'ext2' 'part_msdos' 'biosdisk'


grub-bios-setup  --verbose  --force    --directory='/mnt/boo
t/grub/i386-pc' --device-map='/mnt/boot/grub/' '/dev/sda'

I still have this string of chars in the MBR: GRUB GeomHard DiskRead Error. This puzzles me. The /dev/sda has 1Mib room at the beginning of /dev/sda to store the grub image. So this should be fine. I checked the partition alignment of manjaro partition, fine.

I’m stuck.
Any ideas? Thanks.

Since Linux is installed inside a LBA, I would say there is something broken on the LBA, so that your BIOS / Grub cannot read it correctly. Logical partitions are very nasty and are rather a hack in my view. I guess there is nothing you can do on a LBA.

However, what about adding just a boot partition, which is not a logical partition and mounted at /boot? This boot partition can be flagged with boot instead of the root partition then. Of course, you have to reinstall grub entirely then.

That is the only idea I have here. Otherwise: Reinstall :man_shrugging:

Thanks. Well, I tried a few things but nothing really convincing and stable for the future. It even broke my windows (loadwin.exe). So I decided to erase everything and go with uefi and gpt. I reflashed the Bios to the latest version and reinstalled windows. Another uefi partition for manjaro and installation went OK. Well, I wasn’t expecting so many difficulties to start with…but eventually things seem to be OK now.