Installing Manjaro Unencrypted boot and encrypted root

Unencrypted boot and encrypted root with Calamares
Manjaro 22.1.0 ISO

I have installed Manjaro KDE manual partition on many computers with no problem in the past.

Steps that I’ve always taken:
Manual partition – Free space
File System ext4
Size 800 MiB
Mount point: /boot
FS Label: boot
Flags: boot
No Encrypt

New partition create
Size 228133 Mib
File System: ext4
Mount point: /
FS Label: root

The system boots one time after installation, but it gets stuck after you turn it off and then back on.

I also used this thread, with no success.
I used fat32 for boot, but also didn’t work.

I can install Manjaro successfully if I use the 21.3.7 ISO version. It installs perfectly fine and also boots fast.

I’m assuming something have changed with the new ISOs, but I can’t figure out what that might be.

Nothing’s changed. The guide is not applicable for a MBR system - only EFI.

When you install Manjaro using unencrypted boot - you need 3 partitions - which is what the mentioned guide shows

  1. one partition fat32 for efi
  2. one partition ext for boot
  3. one luks partition for root

You appear to have forgotten the efi partition.

Grub mandates the efi partition to be at /boot/efi

I have tested a barebone install using the mentioned guide and I cannot reproduce what you describe.

You have to remember that - even the decryption prompt has been beautified - you are still limited to the US keyboard layout.

This limitation means that you - if you rely on looking at the keyboard - use passphrase which can be entered using US layout - or memorize where the corresponding symbols are located on the US layout.

The above about keyboard layout appears to have changed with the prompt.

I’ve never had to make a fat32 efi partition with the 21.3.7 ISO version. I suppose things have change since then? In any case, I understand that have to make an additional partition for fat32 for efi.

Are we having two mounts for boot. One ext4 and one efi?
Could you elaborate what size for each mount point?
What is the minimum amount that I can designate to boot?
boot: 500 Mib ext4, and 500 Mib fat32 eft?

If your system is EFI/GPT - It is all in the guide - I suggest you reread it - and follow to the letter.

I believe that should work.

Which I took all from his guide btw

I did exactly as you’d mentioned. It reboots fine the first time, but once I shut the computer off and turn it back on, entering the encryption passphrase, it tries to boot but then it hangs indefinitely. I have 3 times, and still hangs. Needless to mention I have no problem if I use the system encryption or using the Manjaro 21.3.7 ISO version manually.
Also one thing to mention after entering the root and encryption a message pops up stating:

Option to use GPT on BIOS
A GPT partition table is the best option fo all systems. This installer supports such a setup for BIOS system too.

To configure a APT partition table on BIOS (if not done so already) go back and set the partition table to GPT, next create a 8 MiB unformatted partition is necessary to start Manjaro on a BIOS system with GPT.

Maybe I’m missing this step, but what file system, name, mount point and etc.?

According to your first post though you didn’t set fat32 to a /boot/efi parition, unless you mean that you have now and are still experiencing the same issue?

I did exactly as you instructed.
I did have the dash the second time I formatted under mount point - /boot/efi. I sent the wrong picture.




Clearly you are not following the guide - and you are doing something wrong - I believe you are mixing GPT and MBR which will not work.

GPT has no primary / extended partitions - they are all equal.


Your pictures shows a MBR partition layout a second MBR partitioned disk perhaps?


The picture above was when I tried the MBR option. I have reformatted several times and used the GPT partition method with the same result. I can turn the computer off/on a few times and it boots fine, but it hangs after 3rd or 4th reboot. This doesn’t make any sense! There must be a step that I’m missing, but I have no clue what that might be? This is more of curiosity test on my part to find out why this 22.01 ISO is not working! I can use the 21.3.7 and update, which works flawlessly. In fact that’s what I used on my wife’s computer this past weekend. Perhaps this 22.01 version has a bug or something with manual partition/unencrypted boot! I’ll keep trying when a new ISO available and see how it goes. I also appreciate all your help on this! :wink:

This is a quirk of the installer, suggesting to use GPT even after you have already chosen it.

Do you have other disks installed?
Are you dual booting with another OS?
Does your BIOS prompt you for which partition to boot from?
Are you running a Mac?

They install different kernel versions, plus lots of driver updates.

Is any configuration changed after the first successful reboot? For example do you choose a system update, as will be prompted by the package manager?

I’d try to look at the system logs, like in reading logs

To get to the point of being able to read the logs, try boot from the ISO and run manjaro-chroot, like in restore the bootloader but don’t do the restore grub steps.

Maybe the steps need to be tweaked to mount the LUKS partition …

It is without logic to use something completely irrelevant and stating it is documenting you are doing things as prescribed.

If you follow the aforementioned guide to the letter - it works.

You use 22.1.0 and 22.0.1 interchangeably - but they are really two different ISO where 22.1.0 is an improved version fixing the installer killed by OOM killer.

The changes made to enhance the login experience when using encryption is the same whether you choose full encryption or use partial encryption using the guide. The full and minimal ISO is 100% identical for the base system including the Plymouth boot screen.

The test installation I made using the guide - I have now rebooted that system dozens of times - it starts - prompts and load completely as expected.

The test has been made using the latest minimal ISO downloadable from the web site.


Either the system starts or it does not - If your system can be loaded 2,3,4 times then go into stale mode - you have a hardware issue manifesting periodically.

You can press Esc at the encryption prompt - which will switch to text mode - this will reveal more information - when the Plymouth animations shows - press Esc again to return to text mode.

The decryption done by GRUB has improved a lot lately - perhaps you don’t have to do a partial encryption?

1 Like

Do you have other disks installed? No
Are you dual booting with another OS? No
Does your BIOS prompt you for which partition to boot from? No
Are you running a Mac? No

I’m testing this on an old Toshiba SateliteL855 - i3 core - 244 Gib SSD - 8 GiB Ram.
I simply don’t like to the grub to be encrypted as it will cause headache down the road, as it did for a lot of people in that last update! It’s also much slower booting vs. a non-encrypted grub.

Manjaro is my only OS, and I’ve been using it for several years on all my computers, at home and work. I also installed it this past weekend on my wife’s computer. I used the Manjaro 21.3.7 ISO and then did an update, and it works flawlessly! All my systems are encrypted the same way. 800 MiB ext4 boot (unencrypted), and the rest root, ext4 (encrypted). I will try the minimal installation as you mentioned and let you know it goes. Thank you for taking the time and explaining in such detail.

I don’t know what you are thinking …

It is possible to combine bios/gpt - it requires a different partition layout - which is not described in the guide.

Please do not cloud the question with irrelevant information.

Stick to the point … which is an EFI/GPT based partition layout.

Please do not twist the subject … If you are having an unexplainable issue - it is on your side - not Manjaro.

No reason to be offensive. I’m not complaining! I was simply telling you that’s the way I’ve always had installed Manjaro in the past and have had no issues with the a way I partitioned the hard drive. That’s all!


Perhaps this is the missing step that I need?

"Option to use GPT on BIOS
A GPT partition table is the best option for all systems. This installer supports such a setup for BIOS system too.

To configure a APT partition table on BIOS (if not done so already) go back and set the partition table to GPT, next create a 8 MiB unformatted partition (bios grub) is necessary to start Manjaro on a BIOS system with GPT".

I did this and I rebooted fine. Updated the system and rebooted fine. Shut it down and start the computer, and again hanging! So that wasn’t either.

Try downloading and installing Manjaro minimal ISO.

I remembered in the past that some Manjaro full ISOs had the bug with this setup. Boot start failed after installation with my custom partition layout. But Manjaro minimal ISO had no issue.

I tried the minimal install. I even designated 10 MiB unformatted partition to bios-grub (as instructed), and still hangs after the update and a shut down. No big deal. I’ll test it again when the new ISO is available!

One small observation. I don’t know if this has anything to do with this or not.
I have to type the “/efi” manually when I select the free space of 512M for fat32, for the mount point “/boot/efi”. In other words, the “boot/efi” is not in the drop down. Only “/boot”.

Hi, I hope I’m not to late with my answer.
I’ve had the same problem and it not independet of using grub or systemd boot or on the size of /efi or /boot.
I’ve passed the the startup with deleting the ‘splash’ parameter from the kernel start parameters.
You can try it by pressing ‘e’ in grub or systemd boot. Then the parameters are presentet and you can edit them. (see Kernel parameters - ArchWiki for further information)
CU Schorsch


You don’t have the edit option when you manually setup the encryption. I see the “e” option only if you use the system encryption. How ever, I can hit the Esc key really fast to by pass the hanging. Then it goes to the login screen.