Installing manjaro-plasma-mobile on Asus Vivotab Note 8 M80TA


I am trying to install manjaro-plasma-mobile on an old tablet - Asus Vivotab Note 8 M80TA using this: Releases · manjaro/manjaro-plasma-mobile-x64 · GitHub

The live image from the USB works flawlessly and I love it! It would really breathe new life into this old tablet that really struggles running with Windows 10. And it provides a much better touch experience from what I can tell so far.

However calamares fails to install GRUB. Installation fails with

Bootloader installation error
The bootloader could not be installed. The installation command
grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
returned error code 1.

So… I’m not sure where to even start debugging it? There are a lot of similar errors online, but solutions seem to vary greatly depending on the hardware used.

What I can see so far is that it’s using i386 target, though from what I can tell Intel Atom Z3740 supports 64 bit instruction set?

Any help would be greatly appreciated, and I can get any extra info needed.

Did you boot a normal manjaro iso are did you modify it for 32bit efi? Did you already try to chroot and apply the grub-install command by yourself?

I used manjaro-plasma-mobile-22.0-unstable-220824-linux515.iso from the link provided above without any modification. Do you mean to say that while the CPU is listed as supporting 64bit instructions the device itself can be using 32bit efi?

I will try to chroot and apply the grub-install command.

grub-install results in

EFI variables are not supported on this system
grub-install: error: efitbootmgr failed to register the boot entry: No such file or directory

Then after running grub-install --bootloader-id=GRUB --efi-directory=/boot/efi --no-nvram --removable I managed to force it to install, and upon a reboot I was presented with a GRUB prompt. Because of course I forgot to generate any boot entries first.

Chrooted again and ran grub-mkconfig -o /boot/grub/grub.cfg and now it works! I’m succesfully booted into Manjaro Plasma Mobile on Asus Vivotab Note 8.

And just for posterity, this is the chroot procedure I used: howto-chroot-from-or-into-any-linux-distribution/34071

Most of those old intel tablets with cherry trail processors have a 32 bit efi. But in this case, you normally can’t boot a normal usb image. You should then modify it with the script from linuxium or boot it with the help of ventoy or refind. Or maybe you booted in legacy mode (bios - not uefi)
As you said you can boot it from a unmodified image, I guess your asus vivotab has a 64-bit efi. Then you should chroot in the new installed system and installing a 64-efi.

Check first if you booted in efi mode and if it’s 32 bit or 64 bit:

Boot from usb and chroot (manjaro-chroot -a)

Check efi:

cat /sys/firmware/efi/fw_platform_size

If it returns 64 or 32 this indicates the efi mode. If the files not exist, you booted in legacy mode.

According the result reinstall grub in the chroot environment:

→ 64 is 64bit efi:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

→ 32 is 32bit -efi

grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

→ file does not exist is legacy mode, I never tried this but probably installing grub for bios should help:

grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sd? (change to the correct device, can also be /dev/mmc… check first with lsblk)

After grub-install update the grub configuration with:

grub-mkconfig -o /boot/grub/grub.cfg

Maybe read also the wiki:

Maybe I didn’t express myself properly. I solved the issue.

I ran grub-install --bootloader-id=GRUB --efi-directory=/boot/efi --no-nvram --removable and then grub-mkconfig -o /boot/grub/grub.cfg and everything boots now.

OK, you was before me. I’m glad you worked it out.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.