Installing Manjaro on Apple M1 using parrallels

Does anyone know how and if it is possible to install Manjaro on Apple M1 using the new parrallels software? I know you can install ubuntu, Fedora, Kali but not sure about Manjaro KDE.

Would probably be the same procedure as the others. Since it’s probably emulating x64 code.

thanks, I actually downloaded it but unable to complete the installation. I doesn’t recognize the package

What package?

The Manjaro install media is in .ISO format, probably just like the other distros.

i get an unable to locate operating system when I try installing the the arm version.

ARM version won’t work. We don’t support the M1 hardware.

thanks for the input

But the X64 version might run via emulation in Parallels.

I will give it a go now

thanks, I attempted it but unable to complete the installation. This came up

Which one of all the sentences - it will not work - didn’t you understand?

ARM and X86 cannot work together - two different architectures.

Manjaro do not support M1 hardware - there is no way you are going to be able to install any other operating system than Apple macOS.

Dude thanks for the opinion and insight, as you can read above it was solved. I shared the picture based on a suggestion from the previous response.

The problem is the platform and I reckon a lot of users will be confused with this.

Microsoft is following in Apples footsteps or it is the other way around - I don’t know.

Apple produces the M1 based on ARM

Microsoft produces the Surface Pro - in some versions - also based on ARM

This makes it possible for e.g. Parallels to make a bridge between the Windows 10 ARM based version and the ARM based macOS version.

This is the only bridge that is doable - at least for the time being.

This efforts from Apple and Microsoft to push devices which are even more locked down that they used to be - will continue to create confusion as to - what OS will run on a given piece of hardware.

Products such as VMware and VirtualBox will not be able to run on ARM based hardware - at least for the time being.

It is possible to get lowlevel virtualizers like QEMU to emulate ARM hardware and possibly VMware and VirtualBox will makes this possible too - only time will tell - but making such virtualization work is really a task for super-duper-users and not the casual user thinking - I wanna try Linux on my device. Looking forward - a lot of users will fail in this regard.

I have firsthand experience on this confusion as one of my projects - solely based on Windows platform and SQL server - does not work on ARM based Windows devices and as such one of the employees of my client faced some difficulties to get this custom app working - and eventually failed - it was not possible - because the Windows ARM emulates X86 - which in turn does not expand to all kinds of x86_64 services or applications.

Apple follows in the footsteps of Microsoft. Windows 10 on ARM dates back to 2017 and you can argue that it all started with Windows RT. But Windows RT didn’t come with x86 emulation.

I haven’t tried emulating ARM on a x86 machine, but I do know that the other way around is not that super complicated.

And judging from this article, it doesn’t look super complicated either.

But it is true, when you are using QEMU, it will be very slow.

You are right - I completely forgot that …

I think Microsoft has solved some of that puzzle with the Surface Pro X2 - but even then it is confusing that it runs some Windows applications well but others not very well.

I know that’s not exactly your point but ESXI is available on ARM ESXi Arm Edition | VMware Flings
It was thé first time I’ve heard about EFI on raspberry…

1 Like

Thanks to @Darksky, currently Manjaro’s RPi mainline kernel supports EFI booting. I use it for booting with grub.

Edit: I also used it for a KVM VM on a x86 host… slow, but it worked.

Hi folks. Seems there may be some confusion in this thread.

To be clear, Parallels 16.5 for M1 is an ARM virtualisation solution. Both the host OS (Mac OS) and the guest OS (Windows 10 ARM, Linux for ARM, whatever) are ARM. To my knowledge, Parallels 16.5 for M1 does not provide any x86 emulation capabilities (although the guest OS may have its own x86 emulation, as Windows 10 does).

The M1 version of Parallels will NOT accept an x86 OS (Windows, Ubuntu, whatever). It accepts the Insider Build of Windows 10 for ARM64, and then comes with pre-config’d downloads of Ubuntu 20.04 for ARM64, Fedora 33 for ARM64, Kali Linux and Debian for ARM64.

It should be doable to get Manjaro for ARM running under Parallels, but it may require a non-trivial amount of effort. It won’t be as simple as plopping Manjaro for Rpi into Parallels (although the kernel is probably the package that would differ).

I am very lacking in the ability to contribute actual code, but I’m happy to help test if anyone started working on this.