Installing Manjaro on an Old Laptop

I am a new Linux user who is just getting started. I decided to try installing Manjaro on an old laptop.
When I try to Boot with open source driver the laptop screen starts to change colors and Manjaro Live won’t start. Boot with proprietary drivers stops at Reached target graphical interface.
So I tried installing Manjaro Linux 17.1.12 Stable and the installation was successful.
I assume that the problem is related to the kernel version and video card drivers.
How to install the latest version of Manjaro in my case?

My latop is Acer Aspire 8930G.
Thanks for any help!

Just update it and it’ll be the latest version. To do so, run the following from thee terminal:

pamac upgrade

If any errors, please come back and reply with them.

Edit:

This is thee nature of a rolling release, of Manjaro. You have 1 version, and that’s it. So keeping it updated ensures you always have the latest release.

2 Likes

You picked the wrong hardware as entry point

That is a looong time ago

Which GPU? Nvidia GeForce 9700M GT?

The GPU is likely the issue as it requires driver 340.1080 which is no longer available.

1 Like

Thanks for the answer!

Do you mean it’s redundant to mention it?

Yes, it’s an Nvidia GeForce 9700M GT.
It turns out there is no way to install the current version of Manjaro?
Is it possible to use older versions of Manjaro? On Manjaro Linux 17.1.12 I can’t install anything due to keyring issues that I can’t fix.

Nah - I meant - if you are new to Linux - an old laptop with nvidia may prove difficult to get working - but if you are up for the task because you love challenges - then you should barge on …

The problem is the nvidia driver no longer available - unless of course you build it yourself.

As I recall it the removal of 340 is fairly recent - perhaps 12 make that 24+ months.

The archive on osdn may provide you a more recent working ISO - then you can take it from there.

1 Like

Many thanks for the help!

I would try to build it myself, but I can’t get into the Live Environment on the current version to install the system. In that case, should I first install a recent ISO image that uses kernel 5.4 or 5.10, which support the 340xx legacy driver?

I’d say:

  1. Install it using the older ISO.
  2. Ensure the open-source/Nouvou driver is in use.
  3. Update the system fully as described above.
  4. Ensure you are using kernel 5.15 at the latest.
  5. Install the 340xx driver from the AUR:
pamac build nvidia-340xx-lts-dkms
  1. (Hopefullly) Profit!
2 Likes

I’m writing this on a 2009 machine with a GT9400M, running this install of manjaro since 2015. It’s definitely possible to use old hardware if you’re aware of the limitations. Here some tips:

  • install the latest Xfce ‘minimal’ (5.15LTS)
  • setup a swap partition 2x the size of your ram
  • install kernel 5.10LTS as 2nd kernel
  • turn all eye candy off, especially as long as you’re on the open source driver (nvidia 340.108 is tricky to install and to maintain)
  • keep installed apps to a minimum
  • use FreeOffice instead of OpenOffice
  • use firefox to access emails or messengers
  • do one thing at the time, don’t open more than a couple of firefox tabs
  • avoid using suspend and never hibernate, just let the screen go to sleep or power off

If you’re not afraid to open up your laptop change your hard drive to an ssd (makes a huge difference in usability) and max out your ram (around 20$ for 8GB), 4GB will be usable but just.

3 Likes

I followed @philm intructions when the support for 340.108 was dropped, using his pkgbuild file and nvidia-340-dkms. This only works up to 5.10LTS and the pkgbuild has to be edited every time the pkg gets updated which, thankfully, isn’t very often, maybe twice a year. That’s why I said it’s tricky for a beginner. Nouveau should work, though, if suspend is avoided and on the open source driver 5.15LTS does work fine.

3 Likes

I suggested 5.15 because on the AUR page I linked to, it seems patches are provided up until kernel version 5.15.

1 Like

I know, I noticed those nvidia-340xx-lts-dkms packages and wondered if that may have made it easier. However, searching the forum here will most likely bring up the solution @philm provided when the official support stopped, that’s why I mentioned it.

@podgorniy Your ram is maxed out but your lap has 2 drive bays so an ssd upgrade would be easy. This guy’s cleaning it out and changing the cooling paste, (very recommended maintenance procedure to keep temp throttling at a minimum) the drives are at the front. If you have never upgraded it one drive bay should be free: Tutorial: Notebook Zerlegen und reinigen (Acer Aspire 8930G) - YouTube

1 Like

Many thanks for the help! Could you please also explain the reason why an older version of Manjaro is needed? Does it have an older kernel version preinstalled as well as an older video driver preinstalled? I understand the algorithm for solving the problem, but I would like to understand the issue itself in more detail.

I didn’t.
I recommended the LongTimeSupport kernels and since you should have 2 installed, the last 2 are 5.10LTS and 5.15LTS. The latest Xfce minimal image manjaro-xfce–minimal-220816-linux515.iso comes with 5.15LTS so just add 5.10LTS but don’t install any 6 series kernels because they are aimed at more contemporary hardware.
Why I’m using 5.10LTS is explained in my reply to @Mirdarthos. See if you can make it work on the open source driver first.

1 Like

I tried installing Manjaro KDE 21.0(510) and the latest XFCE(515) just now, but unfortunately I still couldn’t get into the Live Environment to install Manjaro. I’ll try the older version now.

Don’t, it will fail on the first upgrade.

Check how you burn your iso. If you do it from Windows make sure you follow the correct procedure, can’t help with that though, just search the forum but I know Ventoy works and it’s available for Win.

I installed Manjaro Linux 17.1.12 without any problems today, as this was the oldest version I found. To write the image I use imagewriter.

wasted effort - this is 5 years old
I doubt that you’ll be able to update it to current without major contorsions

I just wanted to see if I can install an older version to get a rough idea of what the problem is