Installing Manjaro on an old Acer Aspire 8930G laptop

This is the second attempt to install Manjaro on an old Acer Aspire 8930G laptop.
In my previous post, I managed to find out that my Nvidia GeForce 9700M GT video card uses driver 340.1080, which is no longer available.

The current version of the Manjaro distribution and older versions failed to install.
When I try to boot with an open source driver the laptop screen starts to change colors and the Live Environment won’t start. Booting with proprietary drivers stops at Reached target graphical interface.

As an experiment, I only managed to install Manjaro Linux 17.1.12 using proprietary drivers.

Are there any options for me to install an up-to-date Manjaro distribution?
Maybe I could to edit selection before starting the installation, or use tty to do the some setup during the boot of the Live Environment launcher?

Looking at the specs of that model, you are likely to need a low resource desktop. I understand you tried the standard Manjaro install media. Have you tried an sbk spin? They are unofficial community editions. I would recommend the LXQt desktop for that machine.

I tried yesterday, but it didn’t work the same problem. I’ll install Windows again and donate the laptop to charity. For four days, I’ve been trying to install different distros to be a real Linux user on an old 2009 laptop. :smiley:

Last resort as open source/nouveau drivers should work, have you tried installing an older kernel like 4.19? or can you not get to any sort of desktop/tty ?

It doesn’t work with open-source/nouveau drivers because the screen freezes at some point. I have successfully installed only Manjaro Linux 17.1.12 (4.14) with proprietary drivers.


When I install any version with proprietary drivers, the bootloader freezes Reached the target graphical interface, so I can’t get into the Live Environment. However at this point, I have access to the tty, but since I’m a beginner, I need the help of more experienced users to do some manipulations.