Installing Linux Driver for USB WiFi Adapter RTL8814AU

Hi everyone, this is my first post. I ran into an error after ‘Step 9’ on this GitHub page; [GitHub - morrownr/8814au: Linux Driver for USB WiFi Adapters that are based on the RTL8814AU Chipset]. Copy and pasted from an ‘still’ open Terminal it reports the following;

Running version 20210917
Starting installation...
Copying source files to: /usr/src/rtl8814au-
Copying 8814au.conf to: /etc/modprobe.d
Creating symlink /var/lib/dkms/rtl8814au/ -> /usr/src/rtl8814au-
Error! Your kernel headers for kernel 5.10.70-1-MANJARO cannot be found at /usr/lib/modules/5.10.70-1-MANJARO/build or /usr/lib/modules/5.10.70-1-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
An error occurred. dkms build error = 1
Please report this error.

This is above my level of knowledge on how to proceed, but the terminal window is still open awaiting me to point whatever to whatever. The reason I’m installing the driver is because I’m about 40 metres from a tp-link modem, with the speed equivalent of a 56K modem. So I purchased the tp-link USB adapter AC1900 hoping it will boost my speed. Thanks in advance for any help.

Why not install from AUR?

Hi Tomek, excuse my lack of education. I’m a Linux Mint to Manjaro convert. Looking at that page, how do i install that driver and do i have to uninstall the one from GitHub first? Thanks.

Yes. If there is no script for this purpose, you need to remove all files manually.

At first you need to install proper headers for your kernel (linuxXXX-headers, where XXX is your kernel version) and dkms.

pamac install linuxXXX-headers dkms
pamac build rtl8814au-dkms-git

That’s all.

So XXX in my case would be replaced with 5.10.70-1?

There is an uninstall directive on the GitHub page, which i should do first I’m guessing.

No, in that case it will be linux510-headers

OK thank you. Bare with me while i attempt not to break anything. :wink:

It worked! Speed is now 25 Mbps Rx and 20 Mbps Tx.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.