Installing board firmware

To make things short:

I think my problems might be related to the following sentence which pops up when prompting over the download buttons from the official website "requires board firmware on S
PI like Tow-Boot. When my system still managed to boot it used U-Boot not this one…

If you do not have any firmware on the spi then it is better to use Device specific image.

Plus image might not work if you already have a firmware/uboot/bootloader on emmc already which does not allow to boot from sdcard or conflict with the sdcard uboot.

I think I have to give you a couple of details and also ask you questions so you understand better which situation I brought the device in. Firstly I tried to remove the 2 partitions (boot and root) of the eMMC from the graphic interface of the operating system which was on the SD device. Unfortunately I managed to do that only by the boot partition. When I saw that I was failing to remove the second then I tried to format the internal memory with shred. I was only 10% away from finishing the whole thing when I had to do some chores and let the device enter in sleep. I thought it was no big deal but considering the number of complaints I guess this is just another bug of pb pro. I guess this sleep mode blocked the whole procedure and now the internal memory is almost formatted but not quite.

Now I want to ask you where exactly is this SPI located how can I access it. If this is too complicated I should try with a device specific image which I did before and also failed.

I really regret not getting on with the minimal or recovery or light version which kept installing instead of the one with full features. Now I made things even worse.