Installing Awesome WM over Gnome. Resolution wrong & apps missing


I’ve spun up a KVM with Manjaro Gnome and updated it to latest and ran ‘pamac install awesome alacritty’. VM has 8gb memory and 25gb disk allocated

I can log into awesome fine but I got a couple of weird issues.

The screen resolution is defaulting to 1024x768 even though I’ve set it up in gnome to be higher. If I run ~/.xinitrc, it seems to fix the resolution problem but it throws an error and asks me to log out. If I click log out the error disappears and I can use Awesome at the resolution I defined in gnome. I’m a bit of a noob when it comes to xinitrc, but looks like it wants to work but may not be defined correctly. btw I added “exec awesome” to the end of the ~/.xinitrc, but not sure if that’s correct. I removing the exec has same issue when executing ~/.xinitrc

The error thrown is “Oh no something has gone wrong. A problem has occurred and the system can’t recover. All extensions have been disabled as a precaution.” Any ideas?

Other issue is that the apps from gnome are not available. In fact only thing I can see is terminal (which is set to xterm so I switched it to alacritty in rc.lua to fix this). I definitely have apps installed in gnome!

Thanks for any help in advance. Appreciated :slight_smile:

Are you logging into your Gnome desktop and then trying to log into awesome with .xinitrc? If yes then that’s a messed up way. Remove exec awesome from ~/.xinitrc and copy the below contents to /usr/share/xsessions/awesome.desktop to login into awesome through gdm:

[Desktop Entry]
Comment=Highly configurable framework window manager

If your trying to use both at the same time see awesome - ArchWiki

Better if you rely on xrandr. See xrandr - ArchWiki. In 10-monitor.conf use vmware in place of intel. Works in Virtualbox this way.