Installing AnyDesk on Manjaro GNOME

Hello, everyone!

I’m trying to install AnyDesk on my Manjaro GNOME desktop. here are the commands I’m executing:

sudo pacman -Syu

cat /etc/pamac.conf | grep EnableAUR

sudo pamac install anydesk-bin

I managed to install it correctly on the other Manjaro KDE pc I have by following these exact same commands, but on GNOME, even though there are no apparent error messages, and AnyDesk’s icon appear, once I click it, nothing happens. Also, running ‘systemctl status anydesk’ results it’s disabled, and trying to enable it gave no response at all from terminal. What should I do?

Thank you.

The title and the problem description don’t seem to match.

Thank you, sorry about that.

I’m sorry if this is offending, but do you know what the commands do?

Because, this:

…won’t do anything. And this:

…is wrong. sudo shouldn’t be used with pamac. And since AnyDesk is in the AUR:

$ pamac search anydesk
anydesk-bin  6.3.0-1 [Installed]                                                                                                                                                                                                                          AUR
The Fast Remote Desktop Application

It can be easily installed with:

pamac build any6desk-bin

Provided you have the following installed:

  • base-devel metapackage:

    pamac install base-devel
  • Kernel headers for your kernels:

    pamac install $(pamac list --installed --quiet | grep "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

    This will install the headers for all currently, still supported installed kernels.

Hope this helps!


Switch to Xorg, since Anydesk doesn’t support Wayland.


Im not sure if AnyDesk should use at all, since there is a really big security issue.

Sorry i have only german media article about this issue:

My conclusion, get sure your newest AUR AnyDesk Version is no longer affected from this problem.

1 Like

Thank you all for your responses.

@Mirdarthos, you’re absolutely right, I don’t really know much of what each command does. I’m quite a noob when it comes to Linux, terminals, commands, coding… I was following a guide I found online, which I followed in order to manage to install it in KDE.

I already had my doubts this problem was related to Wayland, but now that @megavolt just confirmed it, I have another question, is there a way for me to install Xorg in Manjaro GNOME so that I can have AnyDesk be installed and work there? Is it possible, or even worth doing to begin with?

Now, @Kobold, I saw the articles you sent, and I get it, cyberattack, even though not having used ransomware… still, in our line of work we’re required to be able to manipulate mouse and keyboard of our customers when in help desk. So, how would we do it without AnyDesk? Would you recommend a safer alternative? Would TeamViewer be a better choice? I’ve also installed RustDesk, but I have no idea if it’s actually safer or not.

Again, thank you all for your answers.

Please, please, please, do yourself a favour and don’t follow random tutorials on the 'net. Unlike Windows, Linux tends to have more ways to do the same thing, so something that works for me, won’t necessarily work for you. (And from what I’ve heard, those kind of tutorials are usually inaccurate or outdated.)

It can possibly also cause headaches when you do that, something goes wrong, and you end up he, on the Forum. Like this time.

Instead, find out on the wiki the best way for you, and if you continue to struggle, see if there’s something on the Arch Wiki regarding it, many times the error is common enough that there is a solution there, and if you still don’t manage, feel free to ask on the Forum.

But, the most important thing is to READ. And not just random tutorials, but legitimate sources.

While I don’t know what, if any problem(s) it has, there is TeamViewer. There are also many other remote desktop suits you can look at:


As far as I know, you can simply switch the session to Xorg on the login screen.
Maybe it is not that easy and fast, but it should already be present.

1 Like

Im not a expert, i know there are a few solutions and i just wanted to point to the brand new issue with anydesk right now and its maybe worth to switch to another application till the issue is gone.

I used VNC Viewer for some time, but not sure if its better… but since TeamViewer is from Microsoft (as far as i know), i would stay away from that company.

There should be anytrust to Microsoft since Microsoft new Service Agreement (released in 10/2023) allows to scan and use (specially for KI/Copilot) all your local files.

Unfortunately, my problem persists. I have to use AnyDesk, even though I’d rather not.

I really don’t know what to do here… I tried logging in on my GNOME machine on Xorg, uninstalling/reinstalling AnyDesk from Xorg, but no matter what, I click the icon but nothing happens. The app never opens. In KDE Manjaro, it worked on the first try, but here it just doesn’t seem to work at all!

Please, help! @megavolt @Mirdarthos

Use Rustdesk then.

Anydesk does not currently work with the certificate.
Anydesk has been hacked and therefore a certificate is invalid.
The certificate of “philandro Software GmbH” is revoked.
Anydesk cannot be started under Windows with this certificate.

Some newly built Anydesk clients still have this certificate.
Check your certificates.
It is a rather unfavourable time to run this on Linux.

Alright. I’ll leave it be. No more AnyDesk. This ticket can be closed, thanks everyone.