Installing and Configuring Wine

Hi guys
I am a teacher and i need to open exe files with winehq. when i click on exe file i see error message. Then:

Unhandled exception: page fault on read access to 0x04f0040c in 32-bit code (0x009718d6).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:009718d6 ESP:0031fbcc EBP:0491f11c EFLAGS:00210206(  R- --  I   - -P- )
 EAX:04f0006c EBX:7b620000 ECX:00000001 EDX:000000e8
 ESI:7b620060 EDI:048b0000
Stack dump:
0x0031fbcc:  047b0050 00000001 00000070 003100e8
0x0031fbdc:  0006f11c 7b62ec84 0096e501 00239000
0x0031fbec:  000004ca 0031fc38 00bf15c8 7b620000
0x0031fbfc:  00bf15d4 0097dd4e 0031fc60 0097ddf4
0x0031fc0c:  0031fc38 fffffffe 00000000 00000000
0x0031fc1c:  00000000 00000000 047b0050 047b000c
=>0 0x009718d6 EntryPoint+0xffffffff() in 2019-turkce-el-kitabi (0x0491f11c)
  1 0x00660020 EntryPoint+0xffffffff() in 2019-turkce-el-kitabi (0x00650072)
  2 0x39ffe4a1 (0xa7e84424)
0x009718d6 EntryPoint+0xffffffff in 2019-turkce-el-kitabi: movl	0x0(%eax,%edx,4),%ebp
Module	Address			Debug info	Name (39 modules)
PE	  320000-  343000	Deferred        aclui
PE	  350000-  392000	Deferred        jsproxy
PE	  400000- 1f2e000	Export          2019-turkce-el-kitabi
PE	61b00000-61b8e000	Deferred        sechost
PE	62800000-628e2000	Deferred        usp10
PE	639c0000-63b25000	Deferred        winmm
PE	64540000-64645000	Deferred        winhttp
PE	64b40000-64b80000	Deferred        shcore
PE	65200000-65692000	Deferred        ole32
PE	65980000-6599a000	Deferred        version
PE	66cc0000-66efd000	Deferred        ddraw
PE	67800000-678e8000	Deferred        combase
PE	68c40000-68d22000	Deferred        shlwapi
PE	6a300000-6a6d6000	Deferred        oleaut32
PE	6a900000-6aa92000	Deferred        setupapi
PE	6b4c0000-6b6a8000	Deferred        wininet
PE	6b8c0000-6bad7000	Deferred        comdlg32
PE	6c0c0000-6c10e000	Deferred        imm32
PE	6dbc0000-6dc11000	Deferred        mpr
PE	6e8c0000-6ed35000	Deferred        comctl32
PE	6fb40000-6fc98000	Deferred        d3d9
PE	6fdc0000-6ffca000	Deferred        rpcrt4
PE	71340000-715b9000	Deferred        urlmon
PE	7a840000-7a844000	Deferred        opengl32
PE	7b000000-7b333000	Deferred        kernelbase
PE	7b620000-7b7dc000	Deferred        kernel32
PE	7bc00000-7bebb000	Deferred        ntdll
PE	7c610000-7cf05000	Deferred        shell32
PE	7d9e0000-7d9e4000	Deferred        uxtheme
PE	7e2d0000-7e2d4000	Deferred        winex11
PE	7e3c0000-7e3c4000	Deferred        ws2_32
PE	7e3f0000-7e3f4000	Deferred        iphlpapi
PE	7e460000-7e464000	Deferred        wined3d
PE	7e5e0000-7e5eb000	Deferred        winspool
PE	7e660000-7e748000	Deferred        user32
PE	7e890000-7e897000	Deferred        gdi32
PE	7e9f0000-7e9f4000	Deferred        ucrtbase
PE	7eaf0000-7eaf4000	Deferred        advapi32
PE	7eb40000-7eb43000	Deferred        wow64cpu
process  tid      prio (all id:s are in hex)
00000038 services.exe
	0000003c    0
	00000048    0
	00000054    0
	00000070    0
	00000080    0
	000000a0    0
00000040 explorer.exe
	00000044    0
	000000b0    0
	000000b4    0
	000000b8    0
0000004c plugplay.exe
	00000050    0
	0000005c    0
	00000060    0
	00000064    0
	00000088    0
00000068 winedevice.exe
	0000006c    0
	00000074    0
	00000078    0
	00000084    0
	00000090    0
	00000094    0
00000098 winedevice.exe
	0000009c    0
	000000a4    0
	000000a8    0
	000000ac    0
000000bc (D) Z:\run\media\ender\depo\okul\Belgeler\2019-turkce-el-kitabi.exe
	000000c0    0 <==
	000000cc    0
000000d0 explorer.exe
	000000d4    0
	000000d8    0
	000000dc    0
	000000e0    0
System information:
    Wine build: wine-5.16 (Staging)
    Platform: i386 (WOW64)
    Version: Windows 7
    Host system: Linux
    Host version: 5.8.6-1-MANJARO

Are there lost any dependencies? Please help

On Wine website, sometimes on PlayOnLinux or Lutris, you may find a review of the specific. exe you seek, and if people had achieved to install it, how they managed…

For simple programs, Wine had worked for me, but when it failed, I tried to install some with PlayOnLinux (not only for games). You can try.

For debugging your Wine log, an other one could help more.

1 Like

Most apps should run out of box, but some may need configuration. PlayOnLinux or Lutris provide scripts for many apps (not only games). You can also see rank for your app here

If you don’t find your program there (because is not known), you should configure wine yourself – see WineHQ or any tutorial (like this)

1 Like

Thank you guys. It is looking technically specific things. This file was opening before. I dont understand what hapdend

As mentioned before I would try to find a Lutris script of what you’re trying to install if you can. Trying to install using wine tricks in my opinion has only gotten harder with getting stuff to work. Also be aware that games or apps may suddenly not work even if you install from lutris this is really rare but I experienced it with the vortex mod organizer. The script on there used to work but no longer does. The lesson to that is to just be attentive to the comments on lutris of the script you install. The comments on the script I just mentioned have a bunch of people saying that they’re having issues

I had a program installed directly with wine that worked well. In order to install a game, with POL or Lutris, I followed the tips and installed Winetricks and if I remember Wine-staging instead of Wine.

My 1st program could not be opened anymore. Even after uninstalling all Wine related stuff and reinstalling normal Wine.

I have now specific programs installed with Wine, POL or Lutris, so that I don’t break the configuration.
Maybe an update of your Wine related applications did that.

I configured winetricks create new 32bit prefix install Lutris, POL but didnt work. I am going to uninstall all of wine related stuff with

sudo pacman -Rsun wine-staging wine-gecko wine-mono winetricks

i think its enough for delete all stuff

Feel free for Wine stuff to install and configure your programs in a brand new virtual desktop. To test, to break and after succeeding, repeat the steps in your principal system.

Ditto. I was just giving advice if you wanted to get up and running as fast as possible with windows games and/or apps but if your willing to take the time experiment by all means. Also @Falav is correct. If you installed a game or app via wine directly and then update wine it’ll break. I had this happen to me with a game and the only workaround I found for it is to add the game to lutris because then lutris will manage the update to wine and keep everything in tact.

When this happens, it’s best to stick to a particular Wine version. Another option is to run a Windows VM.