Installer stuck at Started TLP

tlp
nvidia
hybrid
installation

#1

I’m trying to install Manjaro 17.0.1 KDE for the first time on my laptop but I cannot start to run it from a live USB because the installer gets stuck at “Started TLP system startup/shutdown”.
My laptop is an MSI i5 6300 HQ with a Nvidia 940MX GPU and Intel HD graphics.
I searched this issue on google I believe this has got something to do with my Nvidia drivers.
I tried the same setup on another PC with integrated graphics and it worked fine.
I tried selecting non free drivers but still no luck.
Any help would be highly appreciated.


Had to Use 17.1.pre1 Hakoila Installer - Good Long Term?
Error installation manjaro
Started TLP system startup/shutdown.
#2

When you get stuck you can switch to another TTY by Ctrl+Alt+F2, log in with “manjaro” “manjaro”, run nano /var/log/Xorg.0.log, save the contents somewhere and post it later.


#3

@eugen-b Ctrl+Alt+F2 does not work in this case. As a matter of fact, the only way I can use the computer again is by manually shutting it off by pressing the power button for a few seconds


#4

You can try switching into discrete card in your BIOS settings…


#5

I read this thread before and saw you helping out others with the same issue @thefallenrat . Glad you saw this :slight_smile:

I went through all the options in the BIOS menu but I couldn’t find one where I can switch my gpu to discrete mode. What do I do?


#6

I’m sorry, I don’t know the other way besides BIOS settings…

But I could suggest you using 17.0.2 preview iso or maybe Architect iso


#7

My Idea would be then to consider installing with manjaro-architect in the terminal.

  • You can boot with any Manjaro live USB to terminal only mode by passing 3 as boot parameter. (If you need explanation on how to do it feel free to ask.)
  • Then log in, run nmtui if you need a WiFi connection, install manjaro-architect and start it. You can find a tutorial here:
    Installation with Manjaro-Architect ISO
  • After installing the system you hopefully will be able to boot to graphical desktop, otherwise you will need to modify what is in /etc/X11/mhwd.d/

Trying not the preview ISO as fallenrat suggest but the newer -rc2 ISO would be a worthwile idea as well.
https://forum.manjaro.org/t/manjaro-v17-0-2-rc2-released/?source_topic_id=26207


#8

Actually the link that I posted before shows 17.0.2-rc2 as one of the preview releases…


#9

Ah, you’re right! Great suggestion!


#10

As bandwidth and time are both limited resources for me right now, I need to choose whether I should try one of your options or hop to some other distro. I really want to try Manjaro though. Would trying the preview release work?


#11

Seeing that you were having limited bandwidth. I suggest you to follow @eugen-b steps using manjaro-architect with your current live USB, as this is the only best option right now…


#12

It is not sure that he will have a running graphical system after installing with manjaro-architect.

I would suggest to search for the graphics card model on this forum to find out if it works and maybe ask the user.


#13

I found user that has simliar problem ( Started TLP system startup/shutdown ), but managed to installed manjaro successfully by using manjaro-architect …

Try follow this guide :


#14

This search also gives some results. Most of them suggest that Manjaro works with this card.
https://forum.manjaro.org/search?q=Nvidia%20940MX
So, manjaro-architect would be my recommendation, too.
To save bandwidth @dave.sohan you can select a minimal version of a DE, kde-minimal profile is definitely available.


#15

Recently I have come across with this problem.and I have solved it by switching the boot option to uefi(my laptop is dell inspire),might be an answer to someone who tried those tips above and still get stucked.